Apps crashing on exit under LTSP (unless sound disabled) Was Re: Update on bugs in tuxpaint/math/type

Cc’ing tuxpaint-devel, tuxmath-devel, and the libSDL list.On Tue, Jul 28, 2009 at 03:35:15PM -0700, Jordan Erickson wrote:

https://bugs.launchpad.net/ubuntu/+source/tuxpaint/+bug/269082 - check
out my latest comments.

Do you have any idea how we can get this stuff fixed once and for all?
It’s a horrible thing to have this great software lock up and seemingly
kill a thin client session. Very bad aftertaste for people testing this
stuff out. :frowning:

I hate to say it, but I’ve had this type of problem with Tux Paint,
Mplayer, and Firefox (when using Flash, e.g. on YouTube), at various
points using Ubuntu. (Just on a desktop, no LTSP).

Did we determine whether Pulseaudio is being used? Does disabling it
help? You could also possibly try to ask SDL to use different sound
drivers.

Do other games (e.g., Vectoroids or Defendguin (a pair of mine) or SuperTux
or Battle for Wesnoth) exhibit the same behavior? What about non-SDL-based
stuff, like Amarok or other music players, Adobe Flash, etc.?

If they all do, then it’s really an issue at a lower-level. libSDL or
the audio subsystem or drivers. Developers from those projects would be
better suited to actually fix the issue.

I’d love to figure out a work-around (e.g., ask SDL to use a diff. audio
driver via env. variable), though, so that the bugs can finally get
marked fixed, even if the lower-level stuff doesn’t get fixed quickly.

-bill!

Googling around furiously…

urbanterror crash with pulseaudio
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/224399

"the game crashed completly on exit, no sound and the cpu is on
100 percent the hole time.  When i change my ubuntu settings back
to alsa everything works fine."

Re: [HOWTO] SDL sound (read: ALSA) support for Enemy Territory
http://ubuntuforums.org/showthread.php?t=362231&page=14

"You need to have the corresponding libSDL package installed. If
you have libsdl-alsa, SDL apps will use ALSA output (but ALSA support
is broken when using PulseAudio as sound system). To use ESD or
PulseAudio in SDL apps, you'll need libsdl-esd ou libsdl-pulseaudio,
respectively.  Also, you can install libsdl-all to have all sound
outputs, but unless you specify it with the SDL_AUDIODRIVER variable
(as does ET-SDL), the default system used will be ALSA."

[Hedgewars] 0.9.11 Released!
http://www.hedgewars.org/node/1507

"Ubuntu's Pulseaudio is even more broken than usual with SDL.
I've run into the same issues.
hwengine hanging - kill pulseaudio, hwengine will be able to exit
Client sucking up CPU - turn off music and restart - frontend SDL
not playing nice with pulseaudio will be solved."

In all three cases, people seem to be concluding that SDL-that-uses-pulse
works, while generic-SDL-(that-uses-ALSA) causes problems.,

That seems to agree with the SDL mailinglist post that was attached to
the bug regarding the Tux4Kids apps:

ALSA output doesn’t set buffer size (likely fix for pulse problems)
http://www.nabble.com/ALSA-output-doesn’t-set-buffer-size-(likely-fix-for-pulse-problems)-td21457593.html

"I just noticed that the alsa audio output never set the alsa
hardware's buffer size. I think this is why SDL has such latencies
when pulse audio is in use."

So… can someone try installing:

libsdl1.2debian-pulseaudio

and see if the Tux4Kids app (and anyone else) still go berzerk in the
LTSP environments?

(That is, assuming those environs aren’t already using SDL-that-uses-pulse,
in which case I’m at a total loss.)

Thank you!!!

If this does fix it, I’ll also add a note to the Tux Paint website under
"Known Issues", to help spread the word a little more.

-bill!On Tue, Jul 28, 2009 at 04:04:05PM -0700, Bill Kendrick wrote:

On Tue, Jul 28, 2009 at 03:35:15PM -0700, Jordan Erickson wrote:

https://bugs.launchpad.net/ubuntu/+source/tuxpaint/+bug/269082 - check
out my latest comments.

Looks like this solved it! Hurray!

-bill!On Tue, Jul 28, 2009 at 04:28:58PM -0700, Bill Kendrick wrote:

So… can someone try installing:

libsdl1.2debian-pulseaudio