autoconf: doc: modernize grep discussion (08bb0)

https://github.com/libsdl-org/autoconf/commit/08bb0fe5b409a4cd86620f114f4366e62b76ef49

From 08bb0fe5b409a4cd86620f114f4366e62b76ef49 Mon Sep 17 00:00:00 2001
From: Paul Eggert <[EMAIL REDACTED]>
Date: Tue, 29 Dec 2020 22:48:02 -0800
Subject: [PATCH] doc: modernize grep discussion

---
 doc/autoconf.texi | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/doc/autoconf.texi b/doc/autoconf.texi
index 5e17280e..d09aba70 100644
--- a/doc/autoconf.texi
+++ b/doc/autoconf.texi
@@ -19291,8 +19291,8 @@ dir=`AS_DIRNAME(["$file"])` # This is more portable.
 @item @command{egrep}
 @c ------------------
 @prindex @command{egrep}
-Posix 1003.1-2001 no longer requires @command{egrep},
-but many hosts do not yet support the Posix
+Although Posix stopped requiring @command{egrep} in 2001,
+a few traditional hosts (notably Solaris) do not support the Posix
 replacement @code{grep -E}.  Also, some traditional implementations do
 not work on long input lines.  To work around these problems, invoke
 @code{AC_PROG_EGREP} and then use @code{$EGREP}.
@@ -19477,8 +19477,8 @@ expr: More than one '\(' was used.
 @item @command{fgrep}
 @c ------------------
 @prindex @command{fgrep}
-Posix 1003.1-2001 no longer requires @command{fgrep},
-but many hosts do not yet support the Posix
+Although Posix stopped requiring @command{fgrep} in 2001,
+a few traditional hosts (notably Solaris) do not support the Posix
 replacement @code{grep -F}.  Also, some traditional implementations do
 not work on long input lines.  To work around these problems, invoke
 @code{AC_PROG_FGREP} and then use @code{$FGREP}.
@@ -19519,7 +19519,7 @@ portable scripts should not combine @option{-c} with @option{-l},
 as Posix does not allow this.
 
 Some of the options required by Posix are not portable in practice.
-Don't use @samp{grep -q} to suppress output, because many @command{grep}
+Don't use @samp{grep -q} to suppress output, because traditional @command{grep}
 implementations (e.g., Solaris) do not support @option{-q}.
 Don't use @samp{grep -s} to suppress output either, because Posix
 says @option{-s} does not suppress output, only some error messages;
@@ -19537,7 +19537,7 @@ Some traditional @command{grep} implementations do not work on long
 input lines.  On AIX the default @code{grep} silently truncates long
 lines on the input before matching.
 
-Also, many implementations do not support multiple regexps
+Also, traditional implementations do not support multiple regexps
 with @option{-e}: they either reject @option{-e} entirely (e.g., Solaris)
 or honor only the last pattern (e.g., IRIX 6.5 and NeXT).  To
 work around these problems, invoke @code{AC_PROG_GREP} and then use