BUG: changing video mode in opengl + windows

Hi,

In WIN_GL_SetupWindow (SDL12/src/video/wincommon/SDL_wingl.c) you call
WIN_GL_ResetWindow when SetPixelFormat fails.
WIN_GL_ResetWindow cannot properly work in its current state, because there
are several things to update once you’ve created a new window. At least
DirectInput doesn’t work anymore here (which is somewhat annoying for the
player :).
I think you can simply remove that function. Many games don’t try to
recover from that exception, that’s why the newest ATI drivers emulate 16
bpp display in 32 bpp mode so the error never occurs (but the games may run
much slower).

Having SDL_SetVideoMode return NULL would be better than actually setting
the video mode and losing focus, directinput and maybe directsound too. It
also made my previous drivers crash (when switching from 32 bpp windowed to
16 bpp fullscreen).

Thanks in advance :)–
Hibernatus

#ifdef _WIN32
#error I give up!
#endif

In WIN_GL_SetupWindow (SDL12/src/video/wincommon/SDL_wingl.c) you call
WIN_GL_ResetWindow when SetPixelFormat fails.
WIN_GL_ResetWindow cannot properly work in its current state, because there
are several things to update once you’ve created a new window. At least
DirectInput doesn’t work anymore here (which is somewhat annoying for the
player :).
I think you can simply remove that function. Many games don’t try to
recover from that exception, that’s why the newest ATI drivers emulate 16
bpp display in 32 bpp mode so the error never occurs (but the games may run
much slower).

Done. Ideally the code would be fixed to reinitialize the correct things,
but I don’t have time to make the changes and test them out. Volunteers
are welcome to take a crack at it. :slight_smile:

See ya,
-Sam Lantinga, Software Engineer, Blizzard Entertainment