Building SDL_net under VC++ 6.0?

How do I build SDL_net under VC++ 6.0?
It compiles after I comment out the #warning
pragma in SDLnetTCP.c (VC++ chokes on it),
but when it tries to link, it gives me a whole bunch
of “unresolved external symbol” errors… things like
_WSAStartup or _gethostbyname.

How do I fix it? (add a .dll or a .lib to the project
maybe?)

Thanks,
M.C.

How do I build SDL_net under VC++ 6.0?
It compiles after I comment out the #warning
pragma in SDLnetTCP.c (VC++ chokes on it),
but when it tries to link, it gives me a whole bunch
of “unresolved external symbol” errors… things like
_WSAStartup or _gethostbyname.

How do I fix it? (add a .dll or a .lib to the project
maybe?)

this definitely sounds like the solution. i’d vote
to add the winsock2 library to your file…

ws2_32.lib

this library contains both the functions you mention
are unresolved.

this definitely sounds like the solution. i’d vote
to add the winsock2 library to your file…

ws2_32.lib

this library contains both the functions you mention
are unresolved.

Thank you for your help, I’ve just built me a nice
sdlnet.lib. :slight_smile:

M.C.

did you included
wsock32.lib ???> ----- Original Message -----

From: merlecorey@crosswinds.net ()
To:
Sent: Saturday, September 30, 2000 2:12 AM
Subject: [SDL] Building SDL_net under VC++ 6.0?

How do I build SDL_net under VC++ 6.0?
It compiles after I comment out the #warning
pragma in SDLnetTCP.c (VC++ chokes on it),
but when it tries to link, it gives me a whole bunch
of “unresolved external symbol” errors… things like
_WSAStartup or _gethostbyname.

How do I fix it? (add a .dll or a