Can't start SDL app compiled with Visual Studio 2005

Hi!

I have set up my Visual Studio 2005 Prof. to use the development
libraries SDL-devel-1.2.13-VC8.zip. Then I compiled successfully an easy
SDL exampe. But when I start the app, I get the following error message:
“This application has failed to start because the application
configuration is incorrect…”

Google told me, that this problem is known sometimes with VS 2005, when
running an application on other computers, where VS is not installed.

I send the executabe, which refused to start on my PC, to someone else
with VS 2005 installed. And there it runns correctly.

Has anyone ideas how to solve this problem?

Thanks for your time :slight_smile:

Christian

You have to include the MSVS DLLs in the projects directory

C:\Program Files\Microsoft Visual Studio 9.0\VC\redist\x86…

Jesse "JeZ+Lee"
slnthero at aol.com
Silent Hero Productions®
Video Game Design Studio
http://www.SilentHeroProductions.com

Christian Meyer wrote:> Hi!

I have set up my Visual Studio 2005 Prof. to use the development
libraries SDL-devel-1.2.13-VC8.zip. Then I compiled successfully an easy
SDL exampe. But when I start the app, I get the following error message:
“This application has failed to start because the application
configuration is incorrect…”

Google told me, that this problem is known sometimes with VS 2005, when
running an application on other computers, where VS is not installed.

I send the executabe, which refused to start on my PC, to someone else
with VS 2005 installed. And there it runns correctly.

Has anyone ideas how to solve this problem?

Thanks for your time :slight_smile:

Christian


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

Christian

You need the x86 redistributable package from Microsoft. This contains the DLLs necessary for the SDL application to run
on PCs without VS2005.

Sadly, they issued 2 versions of the same package and only one works correctly, I have found v6.0.3790.0 works correctly.
I can send to you if you require, to save you searching microsoft.com

I hope this helps…

Ed> ----- Original Message -----

From: tvgenial@web.de (Christian Meyer)
To: sdl at libsdl.org
Sent: Sunday, 9 March, 2008 10:00:00 PM
Subject: [SDL] can’t start SDL app compiled with Visual Studio 2005

Hi!

I have set up my Visual Studio 2005 Prof. to use the development
libraries SDL-devel-1.2.13-VC8.zip. Then I compiled successfully an easy
SDL exampe. But when I start the app, I get the following error message:
“This application has failed to start because the application
configuration is incorrect…”

Google told me, that this problem is known sometimes with VS 2005, when
running an application on other computers, where VS is not installed.

I send the executabe, which refused to start on my PC, to someone else
with VS 2005 installed. And there it runns correctly.

Has anyone ideas how to solve this problem?

Thanks for your time :slight_smile:

Christian


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

  __________________________________________________________

Sent from Yahoo! Mail.
The World’s Favourite Email http://uk.docs.yahoo.com/nowyoucan.html