Compi

Dear all,
When I compile SDL1.2 under redhat 7.3, there are some errors occur
about the part of alsa,such as “SND_PCM_SFMT_U8 undeclared”,
“snd_pcm_channel_params_t undeclared” and etc.
My alsa version is 0.9.0, maybe the errors is due to the unmatched
version. But the old version of alsa such as 0.5.0 does not match the redhat7.3 with
the linux kernel 2.4.18.
If someone can tell me what Linux kernel version and ALSA version
match SDL1.2?
???

yours lorayin

E: @lorayin

2002-09-10

sdl at libsdl.org schrieb am 11.09.02 06:44:57:

Dear all,
When I compile SDL1.2 under redhat 7.3, there are some errors occur
about the part of alsa,such as “SND_PCM_SFMT_U8 undeclared”,
“snd_pcm_channel_params_t undeclared” and etc.
My alsa version is 0.9.0, maybe the errors is due to the unmatched
version. But the old version of alsa such as 0.5.0 does not match the redhat7.3 with
the linux kernel 2.4.18.
If someone can tell me what Linux kernel version and ALSA version
match SDL1.2?
???

What version of c++ are you using? If it is 2.96.x then don’t wonder it’s known to be buggy.
Use 2.95.3 or the new 3.2.______________________________________________________________________________
WEB.DE MyPage - Ohne Computerkenntnisse in nur 5 Minuten online! Alles
inklusive! Kinderleicht! http://www.das.ist.aber.ne.lustige.sache.ms/

Dear all,
When I compile SDL1.2 under redhat 7.3, there are some errors occur
about the part of alsa,such as “SND_PCM_SFMT_U8 undeclared”,
“snd_pcm_channel_params_t undeclared” and etc.

Try using SDL from CVS:
http://www.libsdl.org/cvs.php

See ya!
-Sam Lantinga, Software Engineer, Blizzard Entertainment