Correctly generating sdl-config

Hello,

When I do ./configure, the generated sdl-config file is:

[…]
–libs)
libdirs="-L${exec_prefix}/lib "
echo $libdirs -lSDL
;;
–static-libs)

–libs|–static-libs)

  libdirs="-L${exec_prefix}/lib "
  echo $libdirs -lSDL  -lm -lgem
  ;;

[…]

And what I need is:

[…]

–libs)

libdirs="-L${exec_prefix}/lib "

echo $libdirs -lSDL

;;

–static-libs)

--libs|--static-libs)
  libdirs="-L${exec_prefix}/lib "
  echo $libdirs -lSDL  -lm -lgem
  ;;

[…]

On Atari, we do not have a dynamic linker, so libraries are always
statically linked. I must have done something the wrong way in my
customized configure.in, but I do not know what.

And does the fact that SDL on Atari will be linked statically is a
problem, regarding the license ? If someone wants to make a commercial
program (without sources), could he use SDL ?–
Patrice Mandin
WWW: http://www.multimania.com/pmandin
Programmeur Linux, Atari
Sp?cialit?: D?veloppement, jeux

Hello,

When I do ./configure, the generated sdl-config file is:

And what I need is:

On Atari, we do not have a dynamic linker, so libraries are always
statically linked. I must have done something the wrong way in my
customized configure.in, but I do not know what.

Perhaps your host check fails?

MadsOn Fri, 23 Nov 2001, Patrice Mandin wrote:


Mads Bondo Dydensborg. @Mads_Bondo_Dydensbor
You know you’re a Linux geek when…

You find the thought of rebooting after installing a piece of software
utterly absurd.
                          
		                          - segfault