Cross compiing SDL for xscale

I’m getting fool trying to XCompile SDL library for a embedded linux distro for
XScale CPU. The toolchain i’m using is armv5tel-hardhat-linux -gnu, having all
bin tools prefixed by a xscale_le- prefix.
I’m trying to XCompile with the given set of parameters to ./configure:

./configure CC=xscale_le-gcc --build=i686-pc-linux-gnu

All seems to work fine and the configure enters the XCompilation mode generating
rthe Makefile.
When I run it, the system tells me for each file “/usr/include is unsafe for
cross compilation”. I guess this should be cause the Makefile takes the wrong
dir for includes files, while taking them from my toolchain folder takes them
the default dir.

I’ve seen within the generated Makefile there’s CEXTRAFLAGS with the -I option
pointing to /usr/include". I cannot understand how to say the configure to avoid
point to this folder: all the bin are found within my toolchain.
I’ve specified within the prefix option the target folder containing all the
stuff, and then manually I’ve modified the makefile trying to move replace the
-I option and it works, I mean the make doesn?t complain anymore, but I’d like
to use the configure without editing after the makefile.
I know somthing is wrong in what I’m doing, nut my point is:

when I run the ./configure, does it recognise autmatically where my toolchain is
and take from it the include and lib correctly? I’m saying this because I’d like
to XCompile further libraries on the XCompiled SDL, and I’d like it will take
the right includes and libs.

I knoe this is a newby question, but it’s difficult to find some examples o this
topic and seems all libraries have a different approach on it.