Cross-compiling (won't use cross sdl-config)

This is probably a FAQ…

I installed the cross compiler and SDL into the /usr/local/cross-tools.

Then I had problems getting the test demos to compile…

I then did ./configure
It still used /usr/bin/sdl-config

I tried --with-sdl-prefix=/usr/local/cross-tools/i386-mingw32
Still used /usr/bin/sdl-config

So I set /usr/local/cross-tools/i386-mingw32/bin to be the first entry of
my path, then tried with both of the above “prefix” options.
Still it used /usr/bin/sdl-config.

I also tried the above --with-exec-prefix as well.

So I finally just copied the cross-tools sdl-config to /usr/bin.
Then it compiles fine, and runs fine on win95.

Am I doing something wrong here, or is configure not working as it’s
supposed to?–
Brian Hayward

This is probably a FAQ…

Did you try removing config.cache?

-Sam Lantinga				(slouken at

Lead Programmer, Loki Entertainment Software–
“Any sufficiently advanced bug is indistinguishable from a feature”
– Rich Kulawiec