Display blink

Hello all,

Awhile ago I reported that my monitor would momentarily blank when SDL_Init()
was being called. I decided to investigate further, so I installed the
SDL-debuginfo version 1.2.11-22 RPM for openSUSE 10.2.

I wrote a simple program that just calls SDL_Init(SDL_VIDEO_INIT) then calls
SDL_Quit().

Using kdbg I stepped through the execution of SDL_Init().

What I was able to determine was that the monitor would blink when the
following line is executed at SDL_x11video.c:320
WM_DELETE_WINDOW = XInternAtom(SDL_Display, “WM_DELETE_WINDOW”, False);

When I step into XInternAtom(), I’m taken to SDL_x11sym.h:68
SDL_X11_SYM(Atom, XInternAtom, (Display *a, _Xconst char *b, Bool c), (a,b,c), return)

It is at that point when the monitor blanks (blinks).

I am able to confirm (using the debugger, I peaked at current_video->name) that the “x11” video driver is being used.

Is anyone else experiencing this blinking behaviour? Is there any other tests I could run to help pin-point the cause?

Here are the stats of my machine:
AMD Athlon 64 X2 4200+
ATI Radeon X1300 Pro 256MB (fglrx 8.32.5)
openSUSE 10.2 kernel 2.6.18.8-0.3-default
SDL -1.2.11-22
SDL-debuginfo-1.2.11-22
X 7.2.0

Your help/input would be greatly appreciated.

Thank you.

Alvin

Awhile ago I reported that my monitor would momentarily blank when SDL_Init()
was being called. I decided to investigate further, so I installed the
SDL-debuginfo version 1.2.11-22 RPM for openSUSE 10.2.

WM_DELETE_WINDOW = XInternAtom(SDL_Display, “WM_DELETE_WINDOW”, False);

That’s wierd, XInternAtom() shouldn’t cause the display to blink. Is it
a window manager bug maybe?

See ya,
-Sam Lantinga, Lead Software Engineer, Blizzard Entertainment

I tried the TWM window manager and I had the same results.

I spent some time stepping through MPlayer. I had discovered the MPlayer no
longer caused the monitor to blink. After stepping through function after
function, I figured out that MPlayer was using XVideo rather than SDL?
However, when I used the “-vo sdl” when launching mplayer, the monitor blink
occurred.

I also added the Modelines to my xorg.conf file. I originally had none. This
made no difference.

I believe the blinking is caused by ATI’s driver. When I set the driver for X
to be fbdev, the blinking did not occur. Even when I disable the 3D part of
fglrx and have only the 2D acceleration, the monitor still goes blank for a
second.

Thanks,

AlvinOn Sunday 17 June 2007 11:24:12 Sam Lantinga wrote:

Awhile ago I reported that my monitor would momentarily blank when
SDL_Init() was being called. I decided to investigate further, so I
installed the SDL-debuginfo version 1.2.11-22 RPM for openSUSE 10.2.

WM_DELETE_WINDOW = XInternAtom(SDL_Display, "WM_DELETE_WINDOW", False);

That’s wierd, XInternAtom() shouldn’t cause the display to blink. Is it
a window manager bug maybe?

See ya,
-Sam Lantinga, Lead Software Engineer, Blizzard Entertainment

Alvin wrote:> On Sunday 17 June 2007 11:24:12 Sam Lantinga wrote:

Awhile ago I reported that my monitor would momentarily blank when
SDL_Init() was being called. I decided to investigate further, so I
installed the SDL-debuginfo version 1.2.11-22 RPM for openSUSE 10.2.

WM_DELETE_WINDOW = XInternAtom(SDL_Display, “WM_DELETE_WINDOW”, False);

That’s wierd, XInternAtom() shouldn’t cause the display to blink. Is it
a window manager bug maybe?

See ya,
-Sam Lantinga, Lead Software Engineer, Blizzard Entertainment

I tried the TWM window manager and I had the same results.

I spent some time stepping through MPlayer. I had discovered the MPlayer no
longer caused the monitor to blink. After stepping through function after
function, I figured out that MPlayer was using XVideo rather than SDL?
However, when I used the “-vo sdl” when launching mplayer, the monitor blink
occurred.

I also added the Modelines to my xorg.conf file. I originally had none. This
made no difference.

I believe the blinking is caused by ATI’s driver. When I set the driver for X
to be fbdev, the blinking did not occur. Even when I disable the 3D part of
fglrx and have only the 2D acceleration, the monitor still goes blank for a
second.

You could also try with the “vesa” driver. If it doesn’t happen either,
you could definitely blame fglrx (and yes, fglrx is known for having bugs).

Stephane

Alvin wrote:

Is anyone else experiencing this blinking behaviour? Is there any other tests I could run to help pin-point the cause?

I had a similar problem in windows, after giving up I found the gfx card
had the fan broken and was seriously damaged (the blink on SDL init and
java applets init was only the first synthom).

Maybe your problem is totally different but if you have another spare
gfx card you can try if it’s not :)–
Bye,
Gabry

Hello !

I believe the blinking is caused by ATI’s driver. When I set the driver
for X
to be fbdev, the blinking did not occur. Even when I disable the 3D part
of
fglrx and have only the 2D acceleration, the monitor still goes blank for
a
second.

If the x.org ati driver works with your
Graphics card maybe test it.

CU

I’m sorry, I’m not quite sure what you mean? From the part of my message that
you quoted, I was trying to say that using ATI’s driver causes the blanking,
regardless if using 3D or 2D acceleration. When I switched to the fbdev x.org
driver, the blinking did not occur.

I have Windows Vista on this machine as well, with the latest Catalyst
drivers. There is no blinking in Windows.

As far as I can tell, the blanking only occurs with SDL apps. When I use
MPlayer, there is no blinking with the XVideo video driver. If I set MPlayer
to use the sdl video driver, the blanking occurs. In all cases, the blanking
occurs when SDL_Init(SDL_INIT_VIDEO) is called.

AlvinOn Tuesday 19 June 2007 10:35:26 Torsten Giebl wrote:

Hello !

I believe the blinking is caused by ATI’s driver. When I set the driver
for X
to be fbdev, the blinking did not occur. Even when I disable the 3D part
of
fglrx and have only the 2D acceleration, the monitor still goes blank for
a
second.

If the x.org ati driver works with your
Graphics card maybe test it.

Hello !

If the x.org ati driver works with your
Graphics card maybe test it.

I’m sorry, I’m not quite sure what you mean? From the part of my message
that
you quoted, I was trying to say that using ATI’s driver causes the
blanking,
regardless if using 3D or 2D acceleration. When I switched to the fbdev
x.org
driver, the blinking did not occur.

Instead using fglrx or fbdev,
try the ati driver from xorg, the open source one.
( If it supports your card. )

CU

According to the open source ati website, the R5x0 series GPUs are not
supported (yet).

I think I found the cause: the DVI connection. When I use the analog
cable, the blinking stops. So, I say the problem is with ATI’s driver.
When I use th fbdev + DVI, everything is fine. Mind you, there is no
2D or 3D acceleration.

I need 2D and 3D acceleration more than the blinking bothers me. I
guess I will just have to live with it. I’ll have to google some more
and find out if there is some magic setting I can put in my xorg.conf
to stop the blinking with the DVI connection.On 6/19/07, Torsten Giebl wrote:

Hello !

If the x.org ati driver works with your
Graphics card maybe test it.

I’m sorry, I’m not quite sure what you mean? From the part of my message
that
you quoted, I was trying to say that using ATI’s driver causes the
blanking,
regardless if using 3D or 2D acceleration. When I switched to the fbdev
x.org
driver, the blinking did not occur.

Instead using fglrx or fbdev,
try the ati driver from xorg, the open source one.
( If it supports your card. )