"ERROR: No available video device" at calling SDL_

Charles Swain wrote:

I’m currently attempting to build and use SDL under Ubuntu
installations. The only solutions I’ve come across ask me to download
and install a bunch of vague packages, which I did on test systems
(and it didn’t solve the problem I’m encountering at ALL). Been at
this for two days, about at my wit’s end here. I’ve tried setting
SDL_VIDEODRIVER to something specific like x11 or fbcon, and on one
test system I managed to get SDL to output something else than “ERROR:
No available video device” with such set to x11 (“ERROR: a bunch of
crap about missing symbols in X Window System labeled libraries”)
(can’t remember the steps or all the vague packages it took to get to
that point) (usually when custom setting such I just wind up with
"ERROR: (name here) not available."). I can’t see what else DISPLAY
could be set to other than :0, mainly because I don’t understand much
about the environment variable.

If an actual solution can be found that doesn’t leave a mess on a test
system, that would be wonderful. I’d really like to be able to move
on past initializing SDL so that I can try out the new video

SDL mailing list
SDL at lists.libsdl.org

Just to be clear - are you wanting SDL 1.2 or SDL 2.0? 1.2 is already available in the repos…

Assuming you want 2.0 (which I don’t think is in the repos until Saucy): On my Ubuntu Precise machine, I just ran “sudo apt-get build-dep sdl-image1.2” (after installing “build-essential”, of course) and I got everything needed for a clean build of SDL2 and SDL2_image (I needed both).

Note: I have seen that “No video device…” message on this machine, but after the next time I updated from from Mercurial and rebuilt the libraries, everything worked fine. So I’d suggest pulling the latest version from Mercurial and working with that, just to be safe.