Errors on building SDL 1.3 (Win32 - MS Visual C )

Errors on building SDL 1.3 (Win32 - MS Visual C )…

Someone please help!

JeZ+Lee

1>------ Build started: Project: SDL, Configuration: Debug Win32 ------
1>Compiling…
1>SDL_active.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\events\SDL_active.c’: No such file or directory
1>SDL_cursor.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\SDL_cursor.c’: No such file or directory
1>SDL_dibevents.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\windib\SDL_dibevents.c’: No such file or directory
1>SDL_dibvideo.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\windib\SDL_dibvideo.c’: No such file or directory
1>SDL_dx5events.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\windx5\SDL_dx5events.c’: No such file or directory
1>SDL_dx5video.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\windx5\SDL_dx5video.c’: No such file or directory
1>SDL_dx5yuv.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\windx5\SDL_dx5yuv.c’: No such file or directory
1>SDL_expose.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\events\SDL_expose.c’: No such file or directory
1>SDL_nullmouse.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\dummy\SDL_nullmouse.c’: No such file or directory
1>SDL_resize.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\events\SDL_resize.c’: No such file or directory
1>SDL_sysevents.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\wincommon\SDL_sysevents.c’: No such file or directory
1>SDL_sysmouse.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\wincommon\SDL_sysmouse.c’: No such file or directory
1>SDL_syswm.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\wincommon\SDL_syswm.c’: No such file or directory
1>SDL_wingl.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\wincommon\SDL_wingl.c’: No such file or directory
1>SDL_yuv.c
1>c1 : fatal error C1083: Cannot open source file:
’…\src\video\SDL_yuv.c’: No such file or directory
1>Generating Code…
1>Build log was saved at
"file://c:\Users\JeZ-l-Lee\Desktop\SDL-1.3\SDL-1.3\VisualC\SDL\Debug\BuildLog.htm"
1>SDL - 15 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Looks to me like you’re missing a lot of files. First, verify that they’re all there. (That’s probably not the problem, but it might be.) If they are, then the problem’s most likely with the relative paths. It was looking for all of them from …\ and can’t find them. That probably means that the folder it’s starting from is set wrong. I don’t know MS Visual C, but I know paths and IDEs and the headaches that they can give you. You’ve got a project file somewhere that says “…\src\events\SDL_active.c” and all the rest in it. Make sure that file’s located correctly relative to the files it’s trying to reference, and make sure MSVC’s starting its path search from the same folder.>----- Original Message ----

From: Jesse P.
Subject: [SDL] Errors on building SDL 1.3 (Win32 - MS Visual C )…

Errors on building SDL 1.3 (Win32 - MS Visual C )…

Someone please help!

JeZ+Lee

i try to avoid including the path in the header and just tell the compiler
to include the path needed. keeps the code cleaner i think.On Sat, 27 Dec 2008, Mason Wheeler wrote:

Looks to me like you’re missing a lot of files. First, verify that they’re all there. (That’s probably not the problem, but it might be.) If they are, then the problem’s most likely with the relative paths. It was looking for all of them from …\ and can’t find them. That probably means that the folder it’s starting from is set wrong. I don’t know MS Visual C, but I know paths and IDEs and the headaches that they can give you. You’ve got a project file somewhere that says “…\src\events\SDL_active.c” and all the rest in it. Make sure that file’s located correctly relative to the files it’s trying to reference, and make sure MSVC’s starting its path search from the same folder.

----- Original Message ----
From: Jesse P.
Subject: [SDL] Errors on building SDL 1.3 (Win32 - MS Visual C )…

Errors on building SDL 1.3 (Win32 - MS Visual C )…

Someone please help!

JeZ+Lee


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org