Event.type == SDL_KEYUP on MacOsX

Hi

I noticed that sometimes event.type == SDL_KEYUP doesn’t work properly on MacOsX (I use Leopard)

my sprite keeps moving on even if I release the key

it doesn’t happen on GNU+Linux and Windows

did anybody notice the same problem??

MandarX------------------------
http://mandarx.xoom.it/index.php?lang=eng

Hi-

It happens sometimes. Just periodically poll to check which keys are pressed down.

AlastairOn 12 Mar 2010, at 09:04, mandarx wrote:

Hi

I noticed that sometimes event.type == SDL_KEYUP doesn’t work properly on MacOsX (I use Leopard)

my sprite keeps moving on even if I release the key

it doesn’t happen on GNU+Linux and Windows

did anybody notice the same problem??

MandarX

http://mandarx.xoom.it/index.php?lang=eng


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

Alastair Lynn wrote:

Hi-
It happens sometimes. Just periodically poll to check which keys are pressed down.
Alastair

ok thanks

MandarX------------------------
http://mandarx.xoom.it/index.php?lang=eng

It happens sometimes. Just periodically poll to check which keys are
pressed down.

Is it a bug in Cocoa or in SDL?

Zoltan

Are you pressing multiple keys? It could be the usual keyboard problem.

Jonny DOn Fri, Mar 12, 2010 at 6:30 AM, Zolt?n K?csi wrote:

It happens sometimes. Just periodically poll to check which keys are
pressed down.

Is it a bug in Cocoa or in SDL?

Zoltan


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

Jonny D wrote:

Are you pressing multiple keys? ?It could be the usual keyboard problem.

Yes

I solved it just checking again if the key is down when I have to move the sprite.------------------------
http://mandarx.xoom.it/index.php?lang=eng