FastEvents Question

I hesitate to ask this for fear that I’m just making a blindingly stupid
error somewhere, but I’m having no end of trouble with Bob Pendleton’s
"fastevents" code. I’m trying to compile it against SDL 1.2.5, which
otherwise works just fine. I can run all the test code ok, I added
SDL_image with no problems, ran showimage to verify everything actually

But when I try to start up a new project using Bob’s fastevents code and
linking against sdl.lib, sdl_net.lib, and sdlmain.lib, it compiles fine,
but the resulting exes never seem to do anything. I either get an
immediate return to the command prompt, with no output whatsoever, or I
get an application hang somewhere.

I’m not well-versed in how to debug an app -and- a series of DLLs all at
the same time, so finding exactly where it’s hanging has been
problematic at best.

I’ve tried compiling both as a windows app and a console app (which
shouldn’t make much difference, since sdlmain seems to handle both cases
just fine), I still get nowhere.

I haven’t tried compiling this particular code under linux yet, though I
do code on both platforms. Everything else (SDL, SDL_image, SDL_net)
compiles fine on both platforms.

Thanks in advance for any advice or help.