Follow-up on SDL_VideoModeOK behaviour

Just a follup-up the my previous question:

I’m on Windows, and I found that the behaviour I described is only occuring
using the “windib” driver. Using the “directx” driver, the call(s) behave as
expected.

JW

I’d guess it’s possibly because the windib driver is unable to
properly select another video mode than the current desktop.

Anyway, you should always use the desktop depth when calling
SDL_SetVideoMode (ie. by setting bpp to 0). Anything else is likely to
create nasty overhead.On 12/6/06, Jan Willem Penterman wrote:

Just a follup-up the my previous question:

I’m on Windows, and I found that the behaviour I described is only occuring
using the “windib” driver. Using the “directx” driver, the call(s) behave as
expected.

  • SR