Full screen mode in WinDIB mode

I recently upgraded SDL from 1.1.2 to 1.1.3

when I run my program in WinDIB mode (no DX installed)
I get this message:

Couldn’t set video mode: No video modes supported

How can I force it to use windowed mode instead of displaying this error?
Is there any flag to set?

Thanks.
Enzo.–
E-mail enzo.gupi at tiscalinet.it
Home page http://enzogupi.interfree.it

I recently upgraded SDL from 1.1.2 to 1.1.3

when I run my program in WinDIB mode (no DX installed)
I get this message:

Couldn’t set video mode: No video modes supported

How can I force it to use windowed mode instead of displaying this error?
Is there any flag to set?

Don’t set the SDL_FULLSCREEN flag, or check and retry setting the video
mode without that flag. If it still fails, it’s a bug in SDL, so please
let me know.

See ya!
-Sam Lantinga, Lead Programmer, Loki Entertainment Software