game-music-emu: bump minimum required cmake version to 3.12 because of string(JOIN ..)

From 618fc176ca0dd032f2bbe9698867ed149096d31e Mon Sep 17 00:00:00 2001
From: Ozkan Sezer <[EMAIL REDACTED]>
Date: Tue, 24 Oct 2023 12:22:40 +0300
Subject: [PATCH] bump minimum required cmake version to 3.12 because of
 string(JOIN ..)

---
 CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba69f5a..6154d6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
 # CMake project definition file.
-cmake_minimum_required(VERSION 3.3...3.5)
+cmake_minimum_required(VERSION 3.12)
 project(libgme)
 
 include(CMakePushCheckState)