Getting error during compiling libSDL version 1.2.14

Hi

I am trying to build xbmc package for which libsdl is its dependency .My
version is 1.2.14 .
But during compilation I am getting following error:

| WinSystemX11.cpp: In member function ‘bool
CWinSystemX11::RefreshGlxContext()’:
| WinSystemX11.cpp:302:25: error: ‘struct SDL_SysWMinfo’ has no member
named ‘info’
| WinSystemX11.cpp:316:21: error: ‘struct SDL_SysWMinfo’ has no member
named ‘info’
| WinSystemX11.cpp:317:21: error: ‘struct SDL_SysWMinfo’ has no member
named ‘info’
| make[1]: *** [WinSystemX11.o] Error 1

Please can anyone help me to find the solution

Regards
C Hoshing

Hi There,

To help you out a bit more, we’ll need to know what operating system you’re
using, and if you’re used the SDL repository or the zip/targz package.

-AlexOn Tue, Nov 8, 2011 at 7:32 AM, chinmaya hoshing wrote:

Hi

I am trying to build xbmc package for which libsdl is its dependency .My
version is 1.2.14 .
But during compilation I am getting following error:

| WinSystemX11.cpp: In member function ‘bool
CWinSystemX11::RefreshGlxContext()’:
| WinSystemX11.cpp:302:25: error: ‘struct SDL_SysWMinfo’ has no member
named ‘info’
| WinSystemX11.cpp:316:21: error: ‘struct SDL_SysWMinfo’ has no member
named ‘info’
| WinSystemX11.cpp:317:21: error: ‘struct SDL_SysWMinfo’ has no member
named ‘info’
| make[1]: *** [WinSystemX11.o] Error 1

Please can anyone help me to find the solution

Regards
C Hoshing


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org