HELP: SDL on iPAQ

Dear all,

I was wondering if someone had successfully compiled SDL for the iPAQ (ARMS).
Any help/pointer would be very much appreciated.
Please let me know.

Many Thanks.
Regards,
-Olivier

What OS? WinCE or Linux?

-bill!
(not that I’ve compiled it for either, but I’ve USED it for the latter)On Mon, Jul 01, 2002 at 04:52:08PM -0400, Olivier Verscheure wrote:

Dear all,

I was wondering if someone had successfully compiled SDL for the iPAQ (ARMS).
Any help/pointer would be very much appreciated.

WinCE… unfortunately. :wink:
Actually, if there is no easy WinCE solution I’ll switch to Linux.
Thanks.

-Olivier> ----- Original Message -----

From: nbs@sonic.net (Bill Kendrick)
To:
Sent: Monday, July 01, 2002 4:56 PM
Subject: Re: [SDL] HELP: SDL on iPAQ

On Mon, Jul 01, 2002 at 04:52:08PM -0400, Olivier Verscheure wrote:

Dear all,

I was wondering if someone had successfully compiled SDL for the iPAQ
(ARMS).

Any help/pointer would be very much appreciated.

What OS? WinCE or Linux?

-bill!
(not that I’ve compiled it for either, but I’ve USED it for the latter)


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

SDL does compile for ARM Linux. It worked on X11 immediately, and with
a bit of tweaking I obtained acceptable performance on the
framebuffer.

I had to set a LOT of environment variables and make some ugly hacks
to the configure script, however. But most of the SDL code worked fine.

-JohnOn Mon, Jul 01, 2002 at 04:52:08PM -0400, Olivier Verscheure wrote:

Dear all,

I was wondering if someone had successfully compiled SDL for the iPAQ (ARMS).
Any help/pointer would be very much appreciated.
Please let me know.


John R. Hall - KG4RUO - Stranded in the Sol System
Student, Georgia Tech; Author, Programming Linux Games

David Hedbor also got it working under Qtopia (e.g., neither X11 nor FB)
on the Zaurus. Also works on iPaqs running Qtopia.

-bill!On Mon, Jul 01, 2002 at 05:09:53PM -0400, John R. Hall wrote:

SDL does compile for ARM Linux. It worked on X11 immediately, and with
a bit of tweaking I obtained acceptable performance on the
framebuffer.

David Hedbor also got it working under Qtopia (e.g., neither X11 nor FB)
on the Zaurus. Also works on iPaqs running Qtopia.

SDL works on WinCE (PocketPC) iPaqs, natively. I was just sent WinCE
patches to SDL_sound. :slight_smile:

–ryan.

“Ryan C. Gordon” wrote:

David Hedbor also got it working under Qtopia (e.g., neither X11 nor FB)
on the Zaurus. Also works on iPaqs running Qtopia.

SDL works on WinCE (PocketPC) iPaqs, natively. I was just sent WinCE
patches to SDL_sound. :slight_smile:

–ryan.


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

Not -natively-, at least not yet… SDL’s been partially converted to WinCE,
but some stuff’s buggy/missing. Sound works, not entirely sure what else.
Video’s shot, anyway; If I as much as INITIALIZE video under ARM WinCE, it
crashes.