Installing SDL_Image (from source) on mac os x


I have mac os x jaguar installed, with SDL installed. I’m building from
source because i’ve tried using the project builder frameworks but i
liked the way of compiling through the command line better. Anyways i
have libpng, and libjpeg installed. I built each of those from source
and when i ran ./configure for SDL_image, i got the warning…--------
checking for SDL - version >= 1.2.0… yes
checking for jpeg_CreateDecompress in -ljpeg… (cached) no
configure: warning: *** Unable to find JPEG library
configure: warning: JPG image loading disabled
checking for png_create_read_struct in -lpng… (cached) no
configure: warning:
*** Unable to find PNG library (

checking for uncompress in -lz… (cached) yes

i also tried installing libpng and libjpeg through fink (did that
successfully), and ran a ./configure --prefix=/sw and i still get those
errors. And i do have the png libraries in my /usr/local/lib directory.

[mike:8:26pm] /usr/local/lib% ls
libSDL- libSDL.dylib libpng.
libpng.a libpng12.a
libSDL-1.2.0.dylib libpng.3.
libpng12. libpng12.dylib
libSDL.a libSDLmain.a
libpng. libpng12.0.dylib pkgconfig
[mike:8:26pm] /usr/local/lib%

Any help would be greatly appreciated.

-Mike Holmquist