Installing SDL to Android Studio using Lazy Foo's tutorial

I’ve got to step 13 on Lazy Foo’s Android Studio tutorial (http://lazyfoo.net/tutorials/SDL/52_hello_mobile/android_windows/index.php#13) but he says “go to File -> Project Structure. Select app under Modules and the set the Source/Target Compatibility to the latest version (currently 1.8):”

but under my ‘Modules’ section I have an entry called ‘android-project’ (and not ‘app’) and when I click on it the options that Lazy Foo says need changing aren’t there. I only have a ‘Dependencies’ tab and not the ‘Properties’ one he suggests. Help!

This is what I get:

sdl

I got the same problem on linux. I fixed it going to this SDK Location tab, and at JDK location I unchecked the embedded jdk and set my system jdk which was /usr/lib/jvm/java-8-openjdk. After rebuilding, this Project structure window looked exactly like in the tutorial with that app entry. Then I could follow the tutorial normally.

Thanks, and when I went back to Android Studio to try out your solution I found Project Structure now looks exactly as Lazy Foo’s screenshot suggests! I had a go at starting his whole tutorial from scratch and I got the same result as before. It looks like at step 13 you need to quit Android Studio and restart it, and then wait a few seconds too for everything to load before selecting Project Studio (I’m on Windows 10 BTW).