IRIX link problems

I’m tring to get SDL 1.2.3 to build on IRIX 6.5, and am running into a
bit of a snag. The build and install seems to go fine, but when I try to
link anything against it (even building the test programs), I find that
a bunch of symbols are undefined in the shared library that was built.

If I run nm on, I get something like

cassatt 86% nm …/…/…/lib/ | grep SDL_mutexV
[259] | 0| 0|FUNC |GLOB |DEFAULT |UNDEF |SDL_mutexV

However, if I run nm on the intermediate ar archives, I find that the
symbol is in fact defined, at least at that point:

cassatt 101% nm thread/.libs/ | grep SDL_mutex
[44] | 0| 0|FUNC |GLOB |DEFAULT |UNDEF |SDL_mutexP
[61] | 0| 0|FUNC |GLOB |DEFAULT |UNDEF |SDL_mutexV
[19] | 288| 124|FUNC |GLOB |DEFAULT |4 |SDL_mutexP
[26] | 412| 124|FUNC |GLOB |DEFAULT |4 |SDL_mutexV

It is listed twice since it is referenced twice in the archive, but the
definition comes from SDL_sysmutex.l and seems to be there properly. I
suspect libtool is doing something silly, but I don’t really know the
internals of libtool to be able to know for sure.

I’ve tried gcc and the MIPSpro compilers (MIPSpro Compilers: Version and had the same problem. I’ve tried it on several different
machines, just in case something was wonky with this particular machine,
and had the same problems. I built it on a Solaris machine and had no

Anyone have any ideas?