libSDL v2.0.12 Mac OS X right click doesn't work


I’ve a toolkit to draw sprites and things for games, it was working just fine with libSDL v2.0.8 for Mac OS X, and then a few months ago I updated to libSDL v2.0.12 but didn’t recompile until today.

I discovered to my great horror that right clicking in the mousepad doesn’t generate any right-button SDL_MOUSEBUTTONDOWN event like before. Only the left-button still generates events. I’m using Mac OS X El Capitan v10.11.6

So I reinstalled libSDL2 v2.0.8 from and it worked just fine. (^^)!

Out of curiosity also tried v2.0.9 and it works. Tried also v2.0.10 and from that version ithe right button of mouse ceased to work.

I know developers can take a lot of time to find the bug.


1 Like

I’ve seen similar bugs! Can you test this thing out for me please? On this thread. ( Events dont fire? SDL_MULTIGESTURE )

Basically, MultiGesture doesnt work from SDL 2.0.6 to 2.0.12 (!!!) on my Mac laptop. I thought it would be fixed already thats why i didn’t report it.

Do you have any Mac laptops to test MultiGesture on? SDL 2.0.8/2.0.9 is a good version to test. It might be a laptop-only bug.