No I/O port permissions [SEC=UNCLASSIFIED]

Hi

On a fresh install of Ubuntu Dapper 6.06 with all the latest patches
installed, and a source compiled version of SDL from 25 June - I get the
following error running any graphics type SDL application.

“Unable to init SDL: No I/O port permissions”

I have tried running some of the applications located in the test
directory of the source, and also my own that work on other machines.

It’s running on a machine with an ATI M22 [Radeon Mobility M300] video
card - I have tried both the ATI and Vesa drivers for X. Same error.

I can run ‘testhread’ and ‘testtimer’ from the test directory - but
nothing that looks like it requires access to the Video.

If I run a program as root, I get a black X screen which requires a
CTRL+ALT+Backspace to bring back to life.

How do I fix this?

Thanks
David._______________________________________________________________________________________________________

The information transmitted is for the use of the intended recipient only and may contain confidential and/or legally privileged material.
Any review, re-transmission, disclosure, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited and may result in severe penalties.
If you have received this e-mail in error please notify the Security Advisor of the Department of Communications, Information Technology and the Arts, telephone (02) 6271-1880 and delete all copies of this transmission together with any attachments.
For all other enquiries please ring (02) 6271-1000.