openGL on /dev/fb (linux)

I’m trying to run the testgl demo over /dev/fb.
It seems to have difficulties hooking up the GL library
(Mesa in my case). Is this known to be working ?
When targetting at X, all is working fine. However, with
/dev/fb I get the output

Vendor : (null)
Renderer : (null)
Version : (null)
Extensions : (null)

SDL_GL_RED_SIZE: requetsed 5, got 1075189492
SDL_GL_GREEN_SIZE: requested 5, got 1075189492
SDL_GL_BLUE_SIZE: requested 5, got 1075189492
SDL_GL_DEPTH_SIZE: requested 16, got 1075189492
SDL_GL_DOUBLEBUFFER: requested 1, got 1075189492

and then it seg faults.

Any help is highly appreciated.

Thanks, Stefan_______________________________________________________

Stefan Seefeld
Departement de Physique
Universite de Montreal
email: @Stefan_Seefeld


  ...ich hab' noch einen Koffer in Berlin...

I’m trying to run the testgl demo over /dev/fb.
It seems to have difficulties hooking up the GL library
(Mesa in my case). Is this known to be working ?
When targetting at X, all is working fine. However, with
/dev/fb I get the output

Vendor : (null)
Renderer : (null)
Version : (null)
Extensions : (null)

SDL_GL_RED_SIZE: requetsed 5, got 1075189492
SDL_GL_GREEN_SIZE: requested 5, got 1075189492
SDL_GL_BLUE_SIZE: requested 5, got 1075189492
SDL_GL_DEPTH_SIZE: requested 16, got 1075189492
SDL_GL_DOUBLEBUFFER: requested 1, got 1075189492

and then it seg faults.

That’s because there isn’t (if memory serves) an fbcon GL driver installed yet.
This is on the “Nicholas Vining List Of Things To Do When I Have Time” list.

However, you should get an error message, I suppose. I’ll send a patch or
something.

Thanks, Stefan

Cheers,

Nicholas