[OS X]Frameworks which call SDL et al

Greets, I’m encountering a lot of problems trying to create an
incredibly simplistic OS X framework to tidy up a little code, which
includes SDL, SDL_image, and SDL_mixer. I’m inexperienced with building
frameworks, but I’ve been able to code a few which don’t include SDL et
al with no problems; I’ve tried every approach to get this to compile,
all to no avail, as I just receive the same error/warning messages in
Project Builder every compile.

The messages in PB -

“warning: could not use precompiled header
’/Users/mark/Library/SDL_image.framework/Headers/SDL_image.p’, because:
warning: header ‘SDL/SDL.h’ overridden.
warning: /Users/mark/Library/Frameworks/SDL.framework/Headers/SDL.h vs.
/Library/Frameworks/SDL.framework/Headers/SDL.h (within the precomp)
(repeats the above messages, but flavoured for SDL_mixer.)
Build failed (see build log for details)”

The messages in the log -

“2003-12-30 19:09:57.818 Project Builder[315] malformed indexing data
from socket 0x22523a0 (prologue=‘pbxindex-begin v1.0 0x00000B73 01/02
/Users/mark/Desktop/sealErrorLog/LogError.c’, epilogue=‘pbxindex-begin
v1.0 0x00000B73 01/02 /Users/mark/Desktop/sealErrorLog/LogError.c’)”



“Opportunity is missed by most people because it is dressed in overalls
and looks like work.”
~Thomas Edison
-------------- next part --------------
A non-text attachment was scrubbed…
Name: not available
Type: text/enriched
Size: 1361 bytes
Desc: not available
URL: http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20031230/ad73eb93/attachment.bin