[patch] fix building with newer freetype

the freetype guys put together a simple patch:
http://freetype.org/freetype2/patches/SDL_ttf-2.0.7-noftinternals.patch

we’ve been using this in Gentoo with both freetype-2.1.10 and freetype-2.2.1

also, ive attached a simple patch for SDL_ttf’s autogen.sh script :wink:
-mike
-------------- next part --------------
A non-text attachment was scrubbed…
Name: not available
Type: application/pgp-signature
Size: 827 bytes
Desc: not available
URL: http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20060904/9aeb4699/attachment.pgp
-------------- next part --------------
A non-text attachment was scrubbed…
Name: SDL_ttf-autogen.patch
Type: text/x-diff
Size: 304 bytes
Desc: not available
URL: http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20060904/9aeb4699/attachment.patch

the freetype guys put together a simple patch:
http://freetype.org/freetype2/patches/SDL_ttf-2.0.7-noftinternals.patch

we’ve been using this in Gentoo with both freetype-2.1.10 and freetype-2.2.1

I put it in the bugtracker, just in case there was a reason for the
current behaviour.

http://bugzilla.libsdl.org/show_bug.cgi?id=320

also, ive attached a simple patch for SDL_ttf’s autogen.sh script :wink:
-aclocal
-automake --foreign --include-deps --add-missing --copy
-autoconf
+aclocal || exit 1
+automake --foreign --include-deps --add-missing --copy || exit 1
+autoconf || exit 1

I’ll go you one better:

autogen.sh (revision 2742)
+++ autogen.sh (working copy)
@@ -1,5 +1,8 @@
#!/bin/sh#
+
+set -e
+
aclocal
automake --foreign --include-deps --add-missing --copy
autoconf

–ryan.