Problem with cross-compiled SDL_mixer-1.1.0


I?ve just updated my SDL stuff to SDL-1.1.7, SDL_image-1.1.0
and SDL_mixer-1.1.0.

When creating the cross-compiled versions (mingw32) of the
libraries, all looked fine. But when trying to run my game
(Rocks?n?Diamonds) under Windows 2000, it failed with error
0xc00000005 (something like “cannot properly init application”;
the message was in German).

When building all the stuff with SDL_mixer-1.0.6 instead,
it worked fine. The only visible difference in this case was
that 1.0.6 gave no DLL, but a bigger SDL_mixer.a (and therefore
a bigger game executable), where 1.1.0 ended with a cross-compiled

When I replacing SDL_mixer.dll with the pre-compiled version
of Pete Shinners, it worked, too. (The only difference in this
case was that Pete?s version was built with additional SMPEG
library, where mine was just plain SDL_mixer without SMPEG.)

Has anybody any idea what might have gone wrong here?

Thanks in advance!

Kind regards,
holger.schemel at