Problems using SDL_WindowID

Are you running the latest SDL from mercurial? I just tried the tutorial and everything runs fine.

santosovich wrote:> Hello. I am attempting to get SDL set up in the Visual Studio 2010 environment and am following the OpenGL 3.2 tutorials found here:

The first tutorial compiles and runs but the second gives me the error: ‘SDL_WindowID’ : undeclared identifier

The second tutorial uses the SDL_WindowID type to create an SDL window and the first uses the SDL_Window type. I have tried searching these forums as well as google for someone with a similar issue but have had no luck. Thanks for your time.

Just took a look at it again just change SDL_WindowID mainwindow; to SDL_Window *mainwindow; and anywhere else you see SDL_WindowID window change it to SDL_Window *window. You will also get error for places where he used *window = SDL_CreateWindow(…) just remove the pointer. And remove the & in front of mainwindow in the main. SDL_WindowID seems to be only available on mac OSX and linux, well it’s the only place I could find it. Originally ran the program on my mac then tried on windows and got the same error

santosovich wrote:> I am using SDL-2.0.0-6559 which was the source snapshot last week obtained at : I am double checking all my setup steps related to Visual Studio right now to make sure I didn’t overlook something.