Pulseaudio 1.1 and 2.1 support

Hello!

I downloaded latest sdl (1.2.15) and trying to compile it with pulseaudio support under fedora 17.
I execute: ./configure
and I see this: "checking for PulseAudio 0.9 support… no"
Looks like it searches for 0.9 version. I have: 1.1-9.fc17 version. And soon fedora 18 will be released with this pulseaudio version: 2.0-4.fc18 or 2.1 (latest).

Does sdl supports pulseaudio 1.1 and 2.1 ?

Why I need it: I am playing a long strategic games (http://springrts.com) and I am often need to change soundcard. From internal 5.1 to usb etc to use headphones or speakers. In “pulseaudio volume control” I can change soundcard at any time (for skype for example), but for sdl game I can’t change soundcard: http://imageshack.us/a/img411/878/sdlgamepulseaudio.png

I think this is because it uses alsa directly, not pulseaudio.

I tried to “set export SDL_AUDIODRIVER=pulse” environment variable, but it does not changed anything. Maybe default fedora sdl was not compilled with pulseaudio support.–
Thank you,
Alexander Lipatov