Receiving sigpending, could be ODE or SDL

Hey guys. I’m having a bit of trouble with my program. I solved the
problem once, but I forgot what I did and I can’t find any information
on the problem again. My program doesn’t run because it receives the
sigpending signal while trying to initialize the timer. Here’s a
backtrace from GDB:

Program received signal SIG32, Real-time event 32.
0x402852e1 in sigpending () from /lib/libc.so.6
(gdb) bt
#0 0x402852e1 in sigpending () from /lib/libc.so.6
#1 0x402853a7 in sigsuspend () from /lib/libc.so.6
#2 0x40c07258 in pthread_getconcurrency () from /lib/libpthread.so.0
#3 0x40c06ac5 in pthread_create () from /lib/libpthread.so.0
#4 0x40165667 in SDL_SYS_CreateThread () from /usr/lib/libSDL-1.2.so.0
#5 0x40165493 in SDL_CreateThread () from /usr/lib/libSDL-1.2.so.0
#6 0x40166643 in SDL_SYS_TimerInit () from /usr/lib/libSDL-1.2.so.0
#7 0x40165fc6 in SDL_TimerInit () from /usr/lib/libSDL-1.2.so.0
#8 0x4011b495 in SDL_InitSubSystem () from /usr/lib/libSDL-1.2.so.0
#9 0x4011b557 in SDL_Init () from /usr/lib/libSDL-1.2.so.0
#10 0x0804a267 in setup () at main.cpp:113
#11 0x08049fda in main (argc=1, argv=0xbffff584) at main.cpp:53

I remember the problem occurring the first time I tried to use ODE, and
I fixed it but I forgot how. I’m running this on Slackware Linux 10.0.
If you guys have any information on how to fix this, that would be
extremely helpful. Thanks in advance.