Request for help: SDL game segfaults in Linux

Greetings!

I’ve got my newest game almost ready: part of the music missing only. I
have developed it on Windows using Dev-C++ IDE with MinGW. It works
great in Windows.

However, every time I’ve tried to make it run on Linux, all I got is a
segfault on SDL_Init(). I’ve backtraced it and it has something to do
with threads, but I don’t quite get it. The funny thing is that I use
exactly the same initialization code in my other game, Formido - which
works all right. I’ve tried it on Mandrake 9.1 and Redhat 9 with the
same result - a segmentation fault.

Now I have packaged the sources with a makefile, and put it ot the
Internet. I request you Linux/SDL users to try it. It builds ok, if you
have SDL and SDL_Image correctly installed. As the game isn’t released
yet (musics not complete), I won’t distribute the data files quite yet.

Now, if you find time to download the sources, build them and try to run
it I’d be grateful. Maybe it’s just my machine that segfaults, I don’t
know. So if you get a segfault, I’m out of luck - unless somebody can
fix it somehow. On the other hand, if you get a sane error about missing
data, it works. Please report all successful efforts to me (tell the
distro you used) and if you can fix the problem it’d be great.

Here’s the link: http://koti.mbnet.fi/lsoft/Delirium/delirium_src.tar.gz

(btw, I’d appreciate if you won’t distribute/hack those sources, as the
game isn’t yet released… After the release - feel free to do what you
want :slight_smile:

Thank you in advance!–
Mika Halttunen
@Mika_Halttunen

Mika Halttunen wrote:

Here’s the link: http://koti.mbnet.fi/lsoft/Delirium/delirium_src.tar.gz

HTTP 404 File not found ?!?

I have managed to open the directory, and it really isn’t there.–
Milan Babuskov
http://njam.sourceforge.net

Here’s the link: http://koti.mbnet.fi/lsoft/Delirium/delirium_src.tar.gz

HTTP 404 File not found ?!?

I have managed to open the directory, and it really isn’t there.

Yeah, the bug was solved and I removed the sources, until I actually
release the game. And sorry about posting that message twice, my ISP had
some very bad lag in emails, so it appeared just recently, and it was
sent week ago. I reposted it back then using my webmail. But anyway, as
I said, the bug is solved now.–
Mika Halttunen
@Mika_Halttunen