Sdl 1.1.5

SDL 1.1.6 refuses to run OpenGL based programs accelerated with Glide2x.
I did try using “export MESA_GLX_FX=fullscreen”. The only fix I found
was to switch to a previous version of SDL.

Did you try compiling SDL 1.1.6 yourself? The release version is linked
with XFree86 4.0 and that conflicts with Glide. I need to mention that on
the list. I have a set of X11 libraries that I link with for release code,
but they aren’t really set up for public use.

I am completely sure that SDL is the cause.

It’s actually a conflict between XFree86 4.0 and Glide.

Glut programs like Mindrover and Quake3 ran perfectly accelerated, but
Not Chromium or any of my own programs, until I switched to an older
version…

Neither MindRover nor Quake3 use GLUT. MindRover uses SDL, and Quake 3
uses X11 and GL directly.

See ya!
-Sam Lantinga, Lead Programmer, Loki Entertainment Software