SDL 1.2.15 on Mountain Lion (10.8.2) -- "Could not initialize SDL Unsupported Display Mode"


Hopefully this is the proper place to place to ask about this…

Long story short, I bought a mid 2011 Mac Mini with OS X 10.8 pre-installed, Dual Core i7 with 8 BG RAM and ATI discreet graphics. I’m trying to run SDLMame based on these simple instructions:

After following these instructions to the letter (famous words), and then trying to use SDLMame by launching it from the terminal:

Could not initialize SDL Unsupported Display Mode

For what it’s worth, I tried putting the SDL.Framework in both:

Neither worked.

I did also try installing XQuartz in case the lack of X11 on OS X had anything to do with it…

Thinking it might be something with my user account, I made a new user, installed everything, and still got the same result. Searching around the web it seems I’m the only one having this issue… This really leads me to believe I’m missing something completely obvious --OR-- there are issues with 2011 mac mini running the ATI cards.

One thing that was really odd… from my reading I gather SDL 1.2.14 had a known “fullscreen” bug in 10.7/10.8 whereby changing the mame.ini from “window 0” to “window 1” did allow SDL mame to launch, but not fullscreen – I did confirm this to be correct for 10.8 however, I also read that 1.2.15 fixed this bug and I should be able to run SDLMame fullscreen (i.e. “window 0” mode). No such luck… yet.

Any thoughts, ideas, or help are extremely appreciated!

Thank you,