SDL and no Window Manager

Hello,
This is hopefully a rather simple question. If I have an SDL
fullscreen application do I need a window manager to be running. I know
I need X, but do I need the services of a window manager? I have
recently been running into a bunch of sound problems when I have a
window manager running with ESD. Some of the time MIX_OpenAudio, or
even XMMS, just don’t work, and all I can assume is that the sound
device gets co-opted by some process that will not let it go.

The funny thing is that the only way I have found to recapture the
audio, is in XMMS I choose the Output device of libOSS use the alternate
device of /dev/dsp1 and /dev/mixer1. Try playing something, doesn’t
work, go back in and change the Output device back to it’s default
configuration and everything works swimmingly. So, my real question is
how can I limit sound to my application to ensure that no process runs
off with the sound device. Any help would be much appreciated.
Thank you
Robert

This is hopefully a rather simple question.  If I have an SDL

fullscreen application do I need a window manager to be running. I know
I need X, but do I need the services of a window manager?

AFAIK you don’t need wm at all

So, my real question is how can I limit sound to my application to ensure
that no process runs off with the sound device.

On Linux you could use:

fuser /dev/dspOn Wed, Nov 20, 2002 at 06:18:54PM -0600, Robert Diel wrote:


http://decopter.sf.net - free unrealistic helicopter simulator

Tried the whole fuser thing, strangely enough it shows that nothing has
control of /dev/dsp or /dev/mixer or /dev/audio. If you can think of
any other way to see whom is attached to the device I can easily
reproduce this effect. It seems that every time I reboot my box I need
to do this work around because something, probably in the GNOME startup,
is taking and not letting go of the sound.
RobertOn Wed, 2002-11-20 at 17:28, Jacek Pop?awski wrote:

On Wed, Nov 20, 2002 at 06:18:54PM -0600, Robert Diel wrote:

This is hopefully a rather simple question.  If I have an SDL

fullscreen application do I need a window manager to be running. I know
I need X, but do I need the services of a window manager?

AFAIK you don’t need wm at all

So, my real question is how can I limit sound to my application to ensure
that no process runs off with the sound device.

On Linux you could use:

fuser /dev/dsp


http://decopter.sf.net - free unrealistic helicopter simulator


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

Can’t help with the audio but just BTW you don’t even need X. Or at least you
don’t seem to need it running since it will start your app using the Linux
frame buffer is you run the SDL app outside of X-Windows. Seems you still
need the libraries installed though.> On Wed, 2002-11-20 at 17:28, Jacek Pop?awski wrote:

On Wed, Nov 20, 2002 at 06:18:54PM -0600, Robert Diel wrote:

This is hopefully a rather simple question.  If I have an SDL

fullscreen application do I need a window manager to be running. I
know I need X, but do I need the services of a window manager?

AFAIK you don’t need wm at all


Brad Pepers
@Brad_Pepers

I would try disabling Gnome’s sound effects. Go to the Sound settings
in Control Center and uncheck “Enable sound server startup”.

Robert Diel wrote:>Tried the whole fuser thing, strangely enough it shows that nothing has

control of /dev/dsp or /dev/mixer or /dev/audio. If you can think of
any other way to see whom is attached to the device I can easily
reproduce this effect. It seems that every time I reboot my box I need
to do this work around because something, probably in the GNOME startup,
is taking and not letting go of the sound.
Robert

On Wed, 2002-11-20 at 17:28, Jacek Pop?awski wrote:

On Wed, Nov 20, 2002 at 06:18:54PM -0600, Robert Diel wrote:

This is hopefully a rather simple question. If I have an SDL
fullscreen application do I need a window manager to be running. I know
I need X, but do I need the services of a window manager?

AFAIK you don’t need wm at all

So, my real question is how can I limit sound to my application to ensure
that no process runs off with the sound device.

On Linux you could use:

fuser /dev/dsp


http://decopter.sf.net - free unrealistic helicopter simulator


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

Doesn’t seem to be set. However, I am using Evolution and Gaim, both of
which have alert sounds, but I wouldn’t think either of these would be
stealing sound on boot up. I don’t quite know of anything else I am
running currently that outputs any sound, or at the very least stealing
the sound.
RobertOn Wed, 2002-11-20 at 18:41, Anthony Lewis wrote:

I would try disabling Gnome’s sound effects. Go to the Sound settings
in Control Center and uncheck “Enable sound server startup”.

Robert Diel wrote:

Tried the whole fuser thing, strangely enough it shows that nothing has
control of /dev/dsp or /dev/mixer or /dev/audio. If you can think of
any other way to see whom is attached to the device I can easily
reproduce this effect. It seems that every time I reboot my box I need
to do this work around because something, probably in the GNOME startup,
is taking and not letting go of the sound.
Robert

On Wed, 2002-11-20 at 17:28, Jacek Pop?awski wrote:

On Wed, Nov 20, 2002 at 06:18:54PM -0600, Robert Diel wrote:

This is hopefully a rather simple question. If I have an SDL
fullscreen application do I need a window manager to be running. I know
I need X, but do I need the services of a window manager?

AFAIK you don’t need wm at all

So, my real question is how can I limit sound to my application to ensure
that no process runs off with the sound device.

On Linux you could use:

fuser /dev/dsp


http://decopter.sf.net - free unrealistic helicopter simulator


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

I just tried running this app outside of X. It didn’t seem to want to
execute. I did setup fullscreen, but it said Couldn’t initialize “SDL:
no available video device”. Is there some other magic word I need in
order to get it to use the frame buffer?
RobertOn Wed, 2002-11-20 at 18:02, Brad Pepers wrote:

On Wed, 2002-11-20 at 17:28, Jacek Pop?awski wrote:

On Wed, Nov 20, 2002 at 06:18:54PM -0600, Robert Diel wrote:

This is hopefully a rather simple question.  If I have an SDL

fullscreen application do I need a window manager to be running. I
know I need X, but do I need the services of a window manager?

AFAIK you don’t need wm at all

Can’t help with the audio but just BTW you don’t even need X. Or at least you
don’t seem to need it running since it will start your app using the Linux
frame buffer is you run the SDL app outside of X-Windows. Seems you still
need the libraries installed though.


Brad Pepers
brad at linuxcanada.com


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl

Even with it not set I’ve often found ESD running anyway, try a:

ps -elf | grep -i esd

And see if it shows up :slight_smile: Then kill the process and see if you have
better luck if it does…On Wed, 2002-11-20 at 20:10, Robert Diel wrote:

Doesn’t seem to be set. However, I am using Evolution and Gaim, both of
which have alert sounds, but I wouldn’t think either of these would be
stealing sound on boot up. I don’t quite know of anything else I am
running currently that outputs any sound, or at the very least stealing
the sound.
Robert

Dr. Evil, no such beast running when I get these creepy errors. I’m
getting totally freaked out by these errors, 'cause they’re different
every time. I normally, running as someone whom has no permission to
access the audio device I get:

Warning: Couldn’t set 11025 Hz 8-bit audio

  • Reason: No available audio device

Now, on top of that I get this, so it seems someone has ran off with my
socket.

esd: Faialed to fix mode of /tmp/.esd to 1777.
Try -trust to force esd to start.
esd: Esound sound daemon unable to create unix domain socket:
/tmp/.esd/socket
The socket is not accessible by esd.
Exiting…

Ok, now it gets really creepy. First time I run this program as root I
get this:

Warning: Couldn’t set 11025 Hz 8-bit audio

  • Reason: Couldn’t set audio fragment spec

Second time it works like a charm.

Umm… is it just me or is something wrong here. It looks like, and
just call this a whole hearted guess, that someone takes the socket. A
root process then tries to wrest the socket back, and then only on exit,
clean up, does it free the socket in effect forcing the next incarnation
of the program that runs to be able to create the socket.

Now, I really don’t care if this is the case or not I just care who the
hell is taking the socket in the first place. Is there a way to log, or
access this file so I can tell which process created it, so I can
permanently remove that process?
Bit late,
RobertOn Thu, 2002-11-21 at 01:54, DrEvil wrote:

On Wed, 2002-11-20 at 20:10, Robert Diel wrote:

Doesn’t seem to be set. However, I am using Evolution and Gaim, both of
which have alert sounds, but I wouldn’t think either of these would be
stealing sound on boot up. I don’t quite know of anything else I am
running currently that outputs any sound, or at the very least stealing
the sound.
Robert

Even with it not set I’ve often found ESD running anyway, try a:

ps -elf | grep -i esd

And see if it shows up :slight_smile: Then kill the process and see if you have
better luck if it does…


SDL mailing list
SDL at libsdl.org
http://www.libsdl.org/mailman/listinfo/sdl