SDL cannot initialize video card

Any advice on the following please? :-

Initializing SDL.
Could not initialize SDL: No available video device.

tin:~# lspci
pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP
bridge (rev 02)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1
IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) 0000:00:07.2 USB
Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) 0000:00:07.3
Bridge: Intel
Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02) 0000:00:0e.0 Ethernet controller:
Intel
Corp. 82557/8/9 [Ethernet Pro 100] (rev 08) 0000:00:10.0 Ethernet
controller: Intel
Corp. 82557/8/9 [Ethernet Pro 100] (rev 05) 0000:00:12.0 Ethernet
controller: Intel
Corp. 82557/8/9 [Ethernet Pro 100] (rev 08) 0000:00:14.0 Multimedia audio
controller: Ensoniq ES1371 [AudioPCI-97] (rev 02) 0000:01:00.0 VGA compatible
controller: Intel Corp. i740 (rev 21)
tin:~#

So video is an Intel 740 and sound is Ensoniq ES1371.

XFree86 Version 4.3.0.1 (Debian 4.3.0-7 20040318043201
root at cyberhq.internal.cyberhqz.com)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.4 i686 [ELF]
Build Date: 18 March 2004

TIA - Keef-------------------
Dartford Kent UK
Webcams @ http://www.cbcadmin.com/webcam.html
& http://cbc.homelinux.com/webcam2/

Any advice on the following please? :-

Initializing SDL.
Could not initialize SDL: No available video device.

Did you read the FAQ?
Did you build SDL or use the precompiled versions?
If you built it yourself, do you have X11 development libraries installed?
I assume you have X11 on your system? :slight_smile:

See ya,
-Sam Lantinga, Software Engineer, Blizzard Entertainment