SDL: direct3d11: fix SDK version requirement for non-CMake build

From d8b53e821e6306d0b1cdabc7565021270fa9a6d3 Mon Sep 17 00:00:00 2001
From: Cameron Gutman <[EMAIL REDACTED]>
Date: Wed, 3 Nov 2021 19:51:18 -0500
Subject: [PATCH] direct3d11: fix SDK version requirement for non-CMake build

The D3D11 renderer requires Direct3D 11.1 (d3d11_1.h), not Direct3D 11.0
(d3d11.h). In terms of SDKs, that's the Windows 8 SDK or later.

We should probably rename HAVE_D3D11_H...
---
 include/SDL_config_windows.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/SDL_config_windows.h b/include/SDL_config_windows.h
index eab51f73df..5853e5dcc7 100644
--- a/include/SDL_config_windows.h
+++ b/include/SDL_config_windows.h
@@ -91,7 +91,7 @@ typedef unsigned int uintptr_t;
 #if defined(_WIN32_MAXVER) && _WIN32_MAXVER >= 0x0A00  /* Windows 10 SDK */
 #define HAVE_WINDOWS_GAMING_INPUT_H 1
 #endif
-#if defined(_WIN32_MAXVER) && _WIN32_MAXVER >= 0x0601  /* Windows 7 SDK */
+#if defined(_WIN32_MAXVER) && _WIN32_MAXVER >= 0x0602  /* Windows 8 SDK */
 #define HAVE_D3D11_H 1
 #endif
 #define HAVE_MMDEVICEAPI_H 1