SDL/e .16.3 don't seem to mix

This morning I downloaded the rpms (and later the SRPMS that I then
build and installed) for SDL-1.0 and Maelstrom-3.0.1, and the tgz for
doom-sdl (the latest; 1.11 I think).

I am running a souped up RH 6.1 (Oct Gnome, e .16.3, etc.)

I was not able to launch Maelstrom from the Gnome Menu link that it
provided upon install.

When I launched from bash, Maelstrom started but did not get the focus;
the launching shell kept the focus and wouldn’t “let go”. I was able to
switch to a console with Ctrl+Alt+F1, and Kill Maelstrom. When I
repeated the procedure but killed Malestrom with ^C to bash, I noticed
that the mouse events were queued up and then performed (windows were
selected, shaded, unshaded, etc.)

When I launced Maelstrom from gnome-run, it worked fine as did normal
mouse focus.

When I launced from bash under kwm, it worked fine.

sdl-doom behaved exactly as I described for Maelstrom.

How can I help figure out what’s going on?

Phil Long

PS – RailRoad Tycoon II and CivCTP which also (I think) use SDL do not
display this behavior.