SDL failing on target machine

I’ve been working on this code for much too long. I have it working perfectly on my development machine and I thought it would go effortlessly onto the target machine (same architecture and os) but alas it’s all jacked up.

i5-4670K, GTX660, Nvidia drivers, Debian Sid
Intel x86 processor, Embedded graphics, i915 drivers / Mesa 10.4.2, Debian Sid

After SDL_CreateWindow I run GetRenderer. This returns NULL but then SDL_GetError has no error text.
This falls in logic to a bit of code that assigns the window a renderer. (Without this code it SEEMS to default to a software renderer)
Software Renderer:
Display is all jacked up (pictured later). It’s fine on my development machine but it seems to ignore all alpha channels on the target machine.
Accelerated Renderer:
Segfaults everywhere but first place is at SDL_ConvertSurface. Seems like basically anything that tries to used the renderer. Before you ask, I do make sure the renderer doesn’t come back NULL when I create it… so it exists in theory.

[Image: ] (

Please tell me I don’t have to abandon this library… I’ve liked it thus far.

Nevermind, I was mixing and matching parts of code that were incompatible. I still don’t know what was with surfaces in this case but rewriting it to use the renderer worked.