SDL(*).h : No file or directory - But they are present in the include path

I am compiling from src (Lincity-NG) in windows 7 and MinGW. I am sure I
have installed all the libs and dependencies. As it './configure’s and
compiles (partially). Just a side note - I have lincity compiling in linux
(ubuntu VM). So I have something to compare against.

Currently I dont understand :

  1. SDL.h ( or others) are not found. I have all the includes correctly. I
    am attaching the configure output

http://pastebin.com/PcuKQRrW

and the jam build step

http://pastebin.com/nxKm7axG – (Part 1) - Some parts skipped - I dont why

  • mkdir sometimes doesnt work correctly. Around line 150.

      mkdir -p "./build/i686-pc-mingw32/optimize/src/gui\PainterGL"
    

    …failed MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterGL …
    …skipped <T!src!gui!>PainterGL\PainterGL.o for lack
    of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
    …skipped <T!src!gui!>PainterGL\TextureGL.o for lack
    of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
    …skipped <T!src!gui!>PainterGL\TextureManagerGL.o for lack
    of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
    MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterSDL

http://pastebin.com/z7L2ffbK – (part 2) – Where it shows SDL.h: no such
file or directory. I think its not in the pastebin file (didnt print).

Here is the screen shot -

I had a hard time installing SDL_mixer and PhysicsFS(oh the nightmares!) -
but finally did it. And I searched on Google for SDL not found issues (they
are a lot) -

also implemented them (including the path even though it was correct) -
But still nada. Hence I turn to you guidance. ( I added the extra include
and sdl.h is present there - Have them at 2 places but also tried with they being in one place.)

$ sdl-config --cflags
-I/usr/local/include/SDL -D_GNU_SOURCE=1 -Dmain=SDL_main -D_REENTRANT

-I/usr/include/SDL

$ sdl-config --libs
-L/usr/local/lib -lmingw32 -lSDLmain -lSDL -mwindows
  1. Also it doesn’t seem to compile and runthe included xmlgettext tool.

    …failed C++
    ./build/i686-pc-mingw32/optimize/src/tools/xmlgettext\main.o …
    …skipped xmlgettext.exe for lack of <T!src!tools!xmlgettext!>main.o…
    …skipped <T!data!>locale/gui\messages.pot for lack of
    xmlgettext.exe…
    XGetText actions too long (max 2046)!

Can anyone help or guess what I am doing wrong here? I am pretty sure I got
all the libs installed, linked and included. I am also including the
configure output (http://pastebin.com/Y86nZg3k) and jam build output(
http://pastebin.com/NegG8794) from my linux compilation which works
perfectly. Any help or pointer will be appreciated. Thanks.

UPDATE

I checked again everything and all the paths - I am quite
sure they are alright - But it still gives the same “SDL.h no such file”
error. In order make sure that I got the installation correct. I took a
simple SDL application off the net and compiled it and its WORKS!! So
at least paths are correct. I used the following command to compile the
test application.

g++ -c test.c `sdl-config --cflags`
g++ -o test test.o 'sdl-config --libs`
./test

What version of SDL are you using? It looks like it’s finding a mix of SDL
1.2 and SDL 2.0 libraries.

Try using sdl2-config rather than sdl-config.On Tue, May 7, 2013 at 6:27 AM, Amit Ahire wrote:

I am compiling from src (Lincity-NG) in windows 7 and MinGW. I am sure I
have installed all the libs and dependencies. As it './configure’s and
compiles (partially). Just a side note - I have lincity compiling in linux
(ubuntu VM). So I have something to compare against.

Currently I dont understand :

  1. SDL.h ( or others) are not found. I have all the includes correctly. I
    am attaching the configure output

http://pastebin.com/PcuKQRrW

and the jam build step

http://pastebin.com/nxKm7axG – (Part 1) - Some parts skipped - I dont
why - mkdir sometimes doesnt work correctly. Around line 150.

    mkdir -p "./build/i686-pc-mingw32/optimize/src/gui\PainterGL"

...failed MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterGL ...
...skipped <T!src!gui!>PainterGL\PainterGL.o for lack

of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureManagerGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterSDL

http://pastebin.com/z7L2ffbK – (part 2) – Where it shows SDL.h: no such
file or directory. I think its not in the pastebin file (didnt print).

Here is the screen shot -
http://i1268.photobucket.com/albums/jj568/amitahire/sdl-h-nada.png

I had a hard time installing SDL_mixer and PhysicsFS(oh the nightmares!) -
but finally did it. And I searched on Google for SDL not found issues (they
are a lot) -

http://stackoverflow.com/questions/14078532/difference-between-includesdl-sdl-h-and-includesdl-h/14078570#14078570

http://stackoverflow.com/questions/10488775/sdl-h-no-such-file-or-directory-found-when-compiling

also implemented them (including the path even though it was correct) -
But still nada. Hence I turn to you guidance. ( I added the extra include
and sdl.h is present there - Have them at 2 places but also tried with they being in one place.)

$ sdl-config --cflags
-I/usr/local/include/SDL -D_GNU_SOURCE=1 -Dmain=SDL_main -D_REENTRANT

-I/usr/include/SDL

$ sdl-config --libs
-L/usr/local/lib -lmingw32 -lSDLmain -lSDL -mwindows
  1. Also it doesn’t seem to compile and runthe included xmlgettext tool.

    …failed C++
    ./build/i686-pc-mingw32/optimize/src/tools/xmlgettext\main.o …
    …skipped xmlgettext.exe for lack of
    <T!src!tools!xmlgettext!>main.o…
    …skipped <T!data!>locale/gui\messages.pot for lack of
    xmlgettext.exe…
    XGetText actions too long (max 2046)!

Can anyone help or guess what I am doing wrong here? I am pretty sure I
got all the libs installed, linked and included. I am also including the
configure output (http://pastebin.com/Y86nZg3k) and jam build output(
http://pastebin.com/NegG8794) from my linux compilation which works
perfectly. Any help or pointer will be appreciated. Thanks.

UPDATE

I checked again everything and all the paths - I am quite
sure they are alright - But it still gives the same "SDL.h no such file"
error. In order make sure that I got the installation correct. I took a
simple SDL application off the net and compiled it and its WORKS!! So
at least paths are correct. I used the following command to compile the
test application.

g++ -c test.c `sdl-config --cflags`
g++ -o test test.o 'sdl-config --libs`
./test

SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

I am quite sure I didnt mix them up. sdl2-config doesnt work.

$ sdl2-config --cflags
sh: sdl2-config: command not foundOn Tue, May 7, 2013 at 11:37 AM, Alex Barry <alex.barry at gmail.com> wrote:

What version of SDL are you using? It looks like it’s finding a mix of
SDL 1.2 and SDL 2.0 libraries.

Try using sdl2-config rather than sdl-config.

On Tue, May 7, 2013 at 6:27 AM, Amit Ahire <@Amit_Ahire> wrote:

I am compiling from src (Lincity-NG) in windows 7 and MinGW. I am sure I
have installed all the libs and dependencies. As it './configure’s and
compiles (partially). Just a side note - I have lincity compiling in linux
(ubuntu VM). So I have something to compare against.

Currently I dont understand :

  1. SDL.h ( or others) are not found. I have all the includes correctly. I
    am attaching the configure output

http://pastebin.com/PcuKQRrW

and the jam build step

http://pastebin.com/nxKm7axG – (Part 1) - Some parts skipped - I dont
why - mkdir sometimes doesnt work correctly. Around line 150.

    mkdir -p "./build/i686-pc-mingw32/optimize/src/gui\PainterGL"

...failed MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterGL


…skipped <T!src!gui!>PainterGL\PainterGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureManagerGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterSDL

http://pastebin.com/z7L2ffbK – (part 2) – Where it shows SDL.h: no
such file or directory. I think its not in the pastebin file (didnt print).

Here is the screen shot -
http://i1268.photobucket.com/albums/jj568/amitahire/sdl-h-nada.png

I had a hard time installing SDL_mixer and PhysicsFS(oh the nightmares!)

  • but finally did it. And I searched on Google for SDL not found issues
    (they are a lot) -

http://stackoverflow.com/questions/14078532/difference-between-includesdl-sdl-h-and-includesdl-h/14078570#14078570

http://stackoverflow.com/questions/10488775/sdl-h-no-such-file-or-directory-found-when-compiling

also implemented them (including the path even though it was correct) -
But still nada. Hence I turn to you guidance. ( I added the extra include
and sdl.h is present there - Have them at 2 places but also tried with they being in one place.)

$ sdl-config --cflags
-I/usr/local/include/SDL -D_GNU_SOURCE=1 -Dmain=SDL_main -D_REENTRANT

-I/usr/include/SDL

$ sdl-config --libs
-L/usr/local/lib -lmingw32 -lSDLmain -lSDL -mwindows
  1. Also it doesn’t seem to compile and runthe included xmlgettext tool.

    …failed C++
    ./build/i686-pc-mingw32/optimize/src/tools/xmlgettext\main.o …
    …skipped xmlgettext.exe for lack of
    <T!src!tools!xmlgettext!>main.o…
    …skipped <T!data!>locale/gui\messages.pot for lack of
    xmlgettext.exe…
    XGetText actions too long (max 2046)!

Can anyone help or guess what I am doing wrong here? I am pretty sure I
got all the libs installed, linked and included. I am also including the
configure output (http://pastebin.com/Y86nZg3k) and jam build output(
http://pastebin.com/NegG8794) from my linux compilation which works
perfectly. Any help or pointer will be appreciated. Thanks.

UPDATE

I checked again everything and all the paths - I am quite
sure they are alright - But it still gives the same "SDL.h no such file"
error. In order make sure that I got the installation correct. I took a
simple SDL application off the net and compiled it and its WORKS!! So
at least paths are correct. I used the following command to compile the
test application.

g++ -c test.c `sdl-config --cflags`
g++ -o test test.o 'sdl-config --libs`
./test

SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

checking for sdl-config… /mingw/bin/sdl-config
checking for SDL - version >= 1.2.5… yes
checking for SDL_mixer >= 1.2… found
checking for SDL_image >= 1.2… found
checking for SDL_ttf >= 2.0.8… found
checking for SDL_gfx >= 2.0.13… found

^ From that, it looks like it’s finding SDL_ttf and SDL_gfx built against
SDL 2 (unless I’m just interpreting that wrong).On Tue, May 7, 2013 at 6:43 AM, Amit Ahire wrote:

I am quite sure I didnt mix them up. sdl2-config doesnt work.

$ sdl2-config --cflags
sh: sdl2-config: command not found

On Tue, May 7, 2013 at 11:37 AM, Alex Barry <@Alex_Barry> wrote:

What version of SDL are you using? It looks like it’s finding a mix of
SDL 1.2 and SDL 2.0 libraries.

Try using sdl2-config rather than sdl-config.

On Tue, May 7, 2013 at 6:27 AM, Amit Ahire wrote:

I am compiling from src (Lincity-NG) in windows 7 and MinGW. I am sure I
have installed all the libs and dependencies. As it './configure’s and
compiles (partially). Just a side note - I have lincity compiling in linux
(ubuntu VM). So I have something to compare against.

Currently I dont understand :

  1. SDL.h ( or others) are not found. I have all the includes correctly.
    I am attaching the configure output

http://pastebin.com/PcuKQRrW

and the jam build step

http://pastebin.com/nxKm7axG – (Part 1) - Some parts skipped - I dont
why - mkdir sometimes doesnt work correctly. Around line 150.

    mkdir -p "./build/i686-pc-mingw32/optimize/src/gui\PainterGL"

...failed MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterGL


…skipped <T!src!gui!>PainterGL\PainterGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureManagerGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterSDL

http://pastebin.com/z7L2ffbK – (part 2) – Where it shows SDL.h: no
such file or directory. I think its not in the pastebin file (didnt print).

Here is the screen shot -
http://i1268.photobucket.com/albums/jj568/amitahire/sdl-h-nada.png

I had a hard time installing SDL_mixer and PhysicsFS(oh the nightmares!)

  • but finally did it. And I searched on Google for SDL not found issues
    (they are a lot) -

http://stackoverflow.com/questions/14078532/difference-between-includesdl-sdl-h-and-includesdl-h/14078570#14078570

http://stackoverflow.com/questions/10488775/sdl-h-no-such-file-or-directory-found-when-compiling

also implemented them (including the path even though it was correct) -
But still nada. Hence I turn to you guidance. ( I added the extra include
and sdl.h is present there - Have them at 2 places but also tried with they being in one place.)

$ sdl-config --cflags
-I/usr/local/include/SDL -D_GNU_SOURCE=1 -Dmain=SDL_main

-D_REENTRANT -I/usr/include/SDL

$ sdl-config --libs
-L/usr/local/lib -lmingw32 -lSDLmain -lSDL -mwindows
  1. Also it doesn’t seem to compile and runthe included xmlgettext tool.

    …failed C++
    ./build/i686-pc-mingw32/optimize/src/tools/xmlgettext\main.o …
    …skipped xmlgettext.exe for lack of
    <T!src!tools!xmlgettext!>main.o…
    …skipped <T!data!>locale/gui\messages.pot for lack of
    xmlgettext.exe…
    XGetText actions too long (max 2046)!

Can anyone help or guess what I am doing wrong here? I am pretty sure I
got all the libs installed, linked and included. I am also including the
configure output (http://pastebin.com/Y86nZg3k) and jam build output(
http://pastebin.com/NegG8794) from my linux compilation which works
perfectly. Any help or pointer will be appreciated. Thanks.

UPDATE

I checked again everything and all the paths - I am quite
sure they are alright - But it still gives the same "SDL.h no such file"
error. In order make sure that I got the installation correct. I took a
simple SDL application off the net and compiled it and its WORKS!! So
at least paths are correct. I used the following command to compile the
test application.

g++ -c test.c `sdl-config --cflags`
g++ -o test test.o 'sdl-config --libs`
./test

SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

No I think they are correct. SDL_ttf and SDL_gfx (2.x) are the lib version
and they are dependent on SDL 1.2 (http://www.libsdl.org/projects/SDL_ttf/)On Tue, May 7, 2013 at 11:46 AM, Alex Barry <alex.barry at gmail.com> wrote:

checking for sdl-config… /mingw/bin/sdl-config
checking for SDL - version >= 1.2.5… yes
checking for SDL_mixer >= 1.2… found
checking for SDL_image >= 1.2… found
checking for SDL_ttf >= 2.0.8… found
checking for SDL_gfx >= 2.0.13… found

^ From that, it looks like it’s finding SDL_ttf and SDL_gfx built against
SDL 2 (unless I’m just interpreting that wrong).

On Tue, May 7, 2013 at 6:43 AM, Amit Ahire <@Amit_Ahire> wrote:

I am quite sure I didnt mix them up. sdl2-config doesnt work.

$ sdl2-config --cflags
sh: sdl2-config: command not found

On Tue, May 7, 2013 at 11:37 AM, Alex Barry <alex.barry at gmail.com> wrote:

What version of SDL are you using? It looks like it’s finding a mix of
SDL 1.2 and SDL 2.0 libraries.

Try using sdl2-config rather than sdl-config.

On Tue, May 7, 2013 at 6:27 AM, Amit Ahire <@Amit_Ahire> wrote:

I am compiling from src (Lincity-NG) in windows 7 and MinGW. I am sure
I have installed all the libs and dependencies. As it './configure’s and
compiles (partially). Just a side note - I have lincity compiling in linux
(ubuntu VM). So I have something to compare against.

Currently I dont understand :

  1. SDL.h ( or others) are not found. I have all the includes correctly.
    I am attaching the configure output

http://pastebin.com/PcuKQRrW

and the jam build step

http://pastebin.com/nxKm7axG – (Part 1) - Some parts skipped - I dont
why - mkdir sometimes doesnt work correctly. Around line 150.

    mkdir -p "./build/i686-pc-mingw32/optimize/src/gui\PainterGL"

...failed MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterGL


…skipped <T!src!gui!>PainterGL\PainterGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
…skipped <T!src!gui!>PainterGL\TextureManagerGL.o for lack
of./build/i686-pc- mingw32/optimize/src/gui\PainterGL…
MkDir1 ./build/i686-pc-mingw32/optimize/src/gui\PainterSDL

http://pastebin.com/z7L2ffbK – (part 2) – Where it shows SDL.h: no
such file or directory. I think its not in the pastebin file (didnt print).

Here is the screen shot -
http://i1268.photobucket.com/albums/jj568/amitahire/sdl-h-nada.png

I had a hard time installing SDL_mixer and PhysicsFS(oh the
nightmares!) - but finally did it. And I searched on Google for SDL not
found issues (they are a lot) -

http://stackoverflow.com/questions/14078532/difference-between-includesdl-sdl-h-and-includesdl-h/14078570#14078570

http://stackoverflow.com/questions/10488775/sdl-h-no-such-file-or-directory-found-when-compiling

also implemented them (including the path even though it was correct)

  • But still nada. Hence I turn to you guidance. ( I added the extra include
    and sdl.h is present there - Have them at 2 places but also tried with they being in one place.)

    $ sdl-config --cflags
    -I/usr/local/include/SDL -D_GNU_SOURCE=1 -Dmain=SDL_main
    -D_REENTRANT -I/usr/include/SDL

    $ sdl-config --libs
    -L/usr/local/lib -lmingw32 -lSDLmain -lSDL -mwindows

  1. Also it doesn’t seem to compile and runthe included xmlgettext tool.

    …failed C++
    ./build/i686-pc-mingw32/optimize/src/tools/xmlgettext\main.o …
    …skipped xmlgettext.exe for lack of
    <T!src!tools!xmlgettext!>main.o…
    …skipped <T!data!>locale/gui\messages.pot for lack of
    xmlgettext.exe…
    XGetText actions too long (max 2046)!

Can anyone help or guess what I am doing wrong here? I am pretty sure I
got all the libs installed, linked and included. I am also including the
configure output (http://pastebin.com/Y86nZg3k) and jam build output(
http://pastebin.com/NegG8794) from my linux compilation which works
perfectly. Any help or pointer will be appreciated. Thanks.

UPDATE

I checked again everything and all the paths - I am quite
sure they are alright - But it still gives the same "SDL.h no such file"
error. In order make sure that I got the installation correct. I took a
simple SDL application off the net and compiled it and its WORKS!! So
at least paths are correct. I used the following command to compile the
test application.

g++ -c test.c `sdl-config --cflags`
g++ -o test test.o 'sdl-config --libs`
./test

SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org


SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

FYI - SDL_gfx (2.0.24) is the SDL 1.2 version, SDL2_gfx (1.0.0) is the
SDL 2.0 version.On 5/7/2013 3:49 AM, Amit Ahire wrote:

No I think they are correct. SDL_ttf and SDL_gfx (2.x) are the lib
version and they are dependent on SDL 1.2
(http://www.libsdl.org/projects/SDL_ttf/)

On Tue, May 7, 2013 at 11:46 AM, Alex Barry <alex.barry at gmail.com <mailto:alex.barry at gmail.com>> wrote:

checking for sdl-config.../mingw/bin/sdl-config
checking for SDL-version>=1.2.5...yes
checking for SDL_mixer>=1.2...found
checking for SDL_image>=1.2...found
checking for SDL_ttf>=2.0.8...found
checking for SDL_gfx>=2.0.13...found

^ From that, it looks like it's finding SDL_ttf and SDL_gfx built
against SDL 2 (unless I'm just interpreting that wrong).


On Tue, May 7, 2013 at 6:43 AM, Amit Ahire <amitahire at gmail.com <mailto:amitahire at gmail.com>> wrote:

    I am quite sure I didnt mix them up. sdl2-config doesnt work.

        $ sdl2-config --cflags
        sh: sdl2-config: command not found



    On Tue, May 7, 2013 at 11:37 AM, Alex Barry <alex.barry at gmail.com <mailto:alex.barry at gmail.com>> wrote:

        What version of SDL are you using?  It looks like it's
        finding a mix of SDL 1.2 and SDL 2.0 libraries.

        Try using sdl2-config rather than sdl-config.


        On Tue, May 7, 2013 at 6:27 AM, Amit Ahire <amitahire at gmail.com <mailto:amitahire at gmail.com>> wrote:

            I am compiling from src (Lincity-NG) in windows 7 and
            MinGW. I am sure I have installed all the libs and
            dependencies. As it './configure's and compiles
            (partially). Just a side note - I have lincity
            compiling in linux (ubuntu VM). So I have something to
            compare against.

            Currently I dont understand :

            1) SDL.h ( or others) are not found. I have all the
            includes correctly. I am attaching the configure output

            http://pastebin.com/PcuKQRrW

            and the jam build step

            http://pastebin.com/nxKm7axG -- (Part 1) - Some parts
            skipped - I dont why - mkdir sometimes doesnt work
            correctly.  Around line 150.

                    mkdir -p
            "./build/i686-pc-mingw32/optimize/src/gui\PainterGL"
                ...failed MkDir1
            ./build/i686-pc-mingw32/optimize/src/gui\PainterGL ...
                ...skipped <T!src!gui!>PainterGL\PainterGL.o for
            lack of<dir>./build/i686-pc-
             mingw32/optimize/src/gui\PainterGL...
                ...skipped <T!src!gui!>PainterGL\TextureGL.o for
            lack of<dir>./build/i686-pc-
            mingw32/optimize/src/gui\PainterGL...
                ...skipped
            <T!src!gui!>PainterGL\TextureManagerGL.o for lack
            of<dir>./build/i686-pc-
            mingw32/optimize/src/gui\PainterGL...
                MkDir1
            ./build/i686-pc-mingw32/optimize/src/gui\PainterSDL

            http://pastebin.com/z7L2ffbK -- (part 2) -- Where it
            shows SDL.h: no such file or directory. I think its
            not in the pastebin file (didnt print).

            Here is the screen shot -
            http://i1268.photobucket.com/albums/jj568/amitahire/sdl-h-nada.png

            I had a hard time installing SDL_mixer and
            PhysicsFS(oh the nightmares!) - but finally did it.
            And I searched on Google for SDL not found issues
            (they are a lot) -

            http://stackoverflow.com/questions/14078532/difference-between-includesdl-sdl-h-and-includesdl-h/14078570#14078570

            http://stackoverflow.com/questions/10488775/sdl-h-no-such-file-or-directory-found-when-compiling

             also implemented them (including the path even though
            it was correct) - But still nada. Hence I turn to you
            guidance. ( I added the extra include and sdl.h is
            present there - Have them at 2 places <not recommended
            I suppose> but also tried with they being in one place.)

                $ sdl-config --cflags
            -I/usr/local/include/SDL -D_GNU_SOURCE=1
            -Dmain=SDL_main -D_REENTRANT -I/usr/include/SDL

                $ sdl-config --libs
            -L/usr/local/lib -lmingw32 -lSDLmain -lSDL -mwindows

            2) Also it doesn't seem to compile and runthe included
            xmlgettext tool.

                ...failed C++
            ./build/i686-pc-mingw32/optimize/src/tools/xmlgettext\main.o
            ...
                ...skipped xmlgettext.exe for lack of
            <T!src!tools!xmlgettext!>main.o...
                ...skipped <T!data!>locale/gui\messages.pot for
            lack of xmlgettext.exe...
                XGetText actions too long (max 2046)!


            Can anyone help or guess what I am doing wrong here? I
            am pretty sure I got all the libs installed, linked
            and included. I am also including the configure output
            (http://pastebin.com/Y86nZg3k) and jam build
            output(http://pastebin.com/NegG8794) from my linux
            compilation which works perfectly. Any help or pointer
            will be appreciated. Thanks.

            **UPDATE**

            I checked again everything and all the paths - I am quite
            sure they are alright - But it still gives the same
            "SDL.h no such file"
            error. In order make sure that I got the installation
            correct. I took a
            simple SDL application off the net and compiled it and
            its WORKS!! So
            at least paths are correct. I used the following
            command to compile the
            test application.

                g++ -c test.c `sdl-config --cflags`
                g++ -o test test.o 'sdl-config --libs`
                ./test

            _______________________________________________
            SDL mailing list
            SDL at lists.libsdl.org <mailto:SDL at lists.libsdl.org>
            http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org



        _______________________________________________
        SDL mailing list
        SDL at lists.libsdl.org <mailto:SDL at lists.libsdl.org>
        http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org



    _______________________________________________
    SDL mailing list
    SDL at lists.libsdl.org <mailto:SDL at lists.libsdl.org>
    http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org



_______________________________________________
SDL mailing list
SDL at lists.libsdl.org <mailto:SDL at lists.libsdl.org>
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org

SDL mailing list
SDL at lists.libsdl.org
http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org