Sdl-linux fbdev fullscreen and x problems

Hi all,

after detecting the facinating possibilites of SDL I’ve tried to compile
and install the SDL 1.1.8 on my BOX (SuSE 7.0 Kernel 2.2.16 running under
fbdev vesamode=788 cause connected over tv-out to the TV in livingroom).
First tries with the included testprogramms run fine at 640x480. But
getting a fullscreen output 800x600 fails allways. Is a Vesafb not
supported ??.. even it looks really nice in 640x480.
The next thing I’ve tried was to start an application (xmps) via a x-server
running on my win32 notebook which uses SDL … this seems to work.
After that I started X on my box and switched from console mode to X and
tried to start the testprogramms on X but this don’t work. The Programm
itself starts and it looks like it tries to use the SDL but nothing happend
… (sysconsole output no demsg nothing important). After login as root (su
-l) the testprogramm works … it switchs to a console (can see the login
prompt) and the test runs but only at 640x480.

Please help …

Thanks in advance and greetings from Germany
Stefan Hagendorn

Here the output from X:

hagie at unimatrix:~ > X -version

XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 1999
If the server is older than 6-12 months, or if your card is newer
than the above date, look for a newer version before reporting
problems. (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.14 i686 [ELF] SuSE
Configured drivers:
FBDev: Server for frame buffer device
(Patchlevel 10): mfb, cfb8, cfb16, cfb24, cfb32