SDL & MikMod Timing problems

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Banzai!

I’ve been playing around with SDL and MikMod and I noticed that all the time
graphics is being rendered faster than sound played…

Sound is all the time lagging behind the graphics, no matter what I do.

I was searching for something similar on the web and I found one post on
linuxgames mailing list from 1999 with the same problem, however instead of
some usefull solution people started to argue which library to use and why
write your own… :wink:

Any ideas?


David!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9wqa3z0dAgYeWS2wRArKGAJwPRQsHjsrUg1gHQVWpjj51WyfNBgCfVOKR
yq/M16i8admOe40Ye4QwezA=
=Ikrw
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1On Friday 01 November 2002 17:07, you wrote:

I was searching for something similar on the web and I found one post on
linuxgames mailing list from 1999 with the same problem, however instead of
some usefull solution people started to argue which library to use and why
write your own… :wink:

Any ideas?

$ export MM_NUMFRAGS=2
$ ./run_the_damn_program

Works like a charm…

It was a MikMod problem… There was too much buffer allocated, this will
reduce maximum number of frags for sound buffer and it will be in sync with
the rest of the program.

PS: This solution works for ALSA drivers, dig in the mikmod source for other
solutions.


David!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9wunIz0dAgYeWS2wRAhe6AKCH9HmZPfLgxIF9TJrao1EAx89w0wCfWCjL
qk6r4MjGHjLeuFS+31dZF+E=
=Eypw
-----END PGP SIGNATURE-----