SDL_mixer: libtool upgrade to 2.4.6 - 2/n: support macOS 11

https://github.com/libsdl-org/SDL_mixer/commit/6c09708ccf89ea4b21a24bc236fca083a842f1e9

From 6c09708ccf89ea4b21a24bc236fca083a842f1e9 Mon Sep 17 00:00:00 2001
From: Ozkan Sezer <[EMAIL REDACTED]>
Date: Thu, 2 Dec 2021 20:50:10 +0300
Subject: [PATCH] libtool upgrade to 2.4.6 - 2/n: support macOS 11

http://git.savannah.gnu.org/gitweb/?p=libtool.git;a=commitdiff;h=9e8c882517082fe5755f2524d23efb02f1522490
http://git.savannah.gnu.org/gitweb/?p=libtool.git;a=commitdiff;h=8f4bdbda0a0c85cf6375a4c7546b83eb3fb596d3
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44605
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44684
---
 acinclude/libtool.m4 | 17 ++++++-----------
 1 file changed, 6 insertions(+), 11 deletions(-)

diff --git a/acinclude/libtool.m4 b/acinclude/libtool.m4
index a3bc337b..0cec55c4 100644
--- a/acinclude/libtool.m4
+++ b/acinclude/libtool.m4
@@ -1067,17 +1067,12 @@ _LT_EOF
       _lt_dar_allow_undefined='$wl-undefined ${wl}suppress' ;;
     darwin1.*)
       _lt_dar_allow_undefined='$wl-flat_namespace $wl-undefined ${wl}suppress' ;;
-    darwin*) # darwin 5.x on
-      # if running on 10.5 or later, the deployment target defaults
-      # to the OS version, if on x86, and 10.4, the deployment
-      # target defaults to 10.4. Don't you love it?
-      case ${MACOSX_DEPLOYMENT_TARGET-10.0},$host in
-	10.0,*86*-darwin8*|10.0,*-darwin[[91]]*)
-	  _lt_dar_allow_undefined='$wl-undefined ${wl}dynamic_lookup' ;;
-	10.[[012]][[,.]]*)
-	  _lt_dar_allow_undefined='$wl-flat_namespace $wl-undefined ${wl}suppress' ;;
-	10.*)
-	  _lt_dar_allow_undefined='$wl-undefined ${wl}dynamic_lookup' ;;
+    darwin*)
+      case ${MACOSX_DEPLOYMENT_TARGET},$host in
+        10.[[012]],*|,*powerpc*-darwin[[5-8]]*)
+          _lt_dar_allow_undefined='$wl-flat_namespace $wl-undefined ${wl}suppress' ;;
+        *)
+          _lt_dar_allow_undefined='$wl-undefined ${wl}dynamic_lookup' ;;
       esac
     ;;
   esac