SDL_mixer MP3_MUSIC not defined

Message: 12>To: sdl at libsdl.org

Subject: Re: [SDL] SDL_mixer: MP3_MUSIC not defined by configure.
From: Sam Lantinga
Date: Sun, 14 Oct 2001 19:47:49 -0700
Reply-To: sdl at libsdl.org

While trying to get mp3 music to play with an application I notice that the -DMP3_MUSIC parameter is not being set by configure.

SDL_mixer uses SMPEG to do the MP3 decoding, so you have to have that
installed. You can get it from Loki:
http://www.lokigames.com/development/smpeg.php3
(if I remember correctly)

You need to add -DMP3_MUSIC to the configure.in file in the section where smpeg is detected, while smpeg is detected fine there are some things in the source code that depends on this. I’m using linux btw.

I notice that this has already been fixed in the CVS:

AC_ARG_ENABLE(music-mp3,
[ --enable-music-mp3 enable MP3 music via smpeg [default=yes]],
, enable_music_mp3=yes)
if test x$enable_music_mp3 = xyes; then
SMPEG_VERSION=0.4.3
AM_PATH_SMPEG($SMPEG_VERSION, have_smpeg=yes, have_smpeg=no)
if test x$have_smpeg = xyes; then
CFLAGS="$CFLAGS -DMP3_MUSIC $SMPEG_CFLAGS"
LIBS="$LIBS $SMPEG_LIBS"
fi
fi

This is what is in 1.2.0:

AC_ARG_ENABLE(music-mp3,
[ --enable-music-mp3 enable MP3 music via smpeg [default=yes]],
, enable_music_mp3=yes)
if test x$enable_music_mp3 = xyes; then
SMPEG_VERSION=0.4.3
AM_PATH_SMPEG($SMPEG_VERSION, have_smpeg=yes, have_smpeg=no)
if test x$have_smpeg = xyes; then
CFLAGS="$CFLAGS $SMPEG_CFLAGS"
LIBS="$LIBS $SMPEG_LIBS"
fi

-Sam Lantinga, Software Engineer, Blizzard Entertainment


Get your free email at
http://freemail.shooters.com/

You need to add -DMP3_MUSIC to the configure.in file in the section where smpeg is detected, while smpeg is detected fine there are some things in the source code that depends on this. I’m using linux btw.

I notice that this has already been fixed in the CVS:

Thanks for the heads up. I really have to release this code ASAP.

See ya,
-Sam Lantinga, Software Engineer, Blizzard Entertainment