SDL program does'nt output anything to the console need help

Hi, I’m using a .bat to call my program everything works fine except that I don’t see any of the messages in the console.
If I call the program directly from the .exe the console displays everything as it’s meant to. The problem only occurs after I compile the program, if i don’t compile the program then the .bat works as if i was calling directly from .exe, after i compile i need to restart my pc for the .bat to work again.

I’m also using a batch file to compile:

cd C:…
gcc Run.c -I C:\sdl\i686-w64-mingw32\include\SDL2 -I C:… -I C:… -LC:\sdl\i686-w64-mingw32\lib -w -Wl,-subsystem,windows -lmingw32 -lSDL2main -lSDL2 -lSDL2_image -lSDL2_ttf -lSDL2_mixer -o C:…

//Tried removing pause

This is the code of the .bat:

cd C:…
//if i use start run.exe no console displays at all

I googled the issue and did some research but i cant find any relate able problems. Please help thank you!

Found the problem, and sorry for the miss leading information, the .bat file which calls the run.exe worked fine after i compiled the program using code blocks so the issue was with the compiler .bat, and computer restart was irrelevant i just didn’t trace back my steps correctly sorry , once i removed “-w -Wl,-subsystem,windows” everything was back to normal.