SDL test program failed - Interesting..?

I’m a novice linux user but i’d like to share an interesting problem/solution
i had. I downloaded and installed SDL-1.1.7 and everything went fine, but
when i tried to compile the ./test programs or any SDL-requiring program i
would get the error message from ./configure:--------------------------
checking for sdl-config… (cached) /usr/local/bin/sdl-config
checking for SDL - version >= 1.1.5… no
*** Could not run SDL test program, checking why…
*** The test program failed to compile or link. See the file config.log for
*** exact error that occured. This usually means SDL was incorrectly installed
*** or that you have moved SDL since it was installed. In the latter case, you
*** may want to edit the sdl-config script: /usr/local/bin/sdl-config
configure: error: *** SDL version 1.1.5 not found!

I couldn’t figure out what the problem was, I searched the SDL site, checked
my /etc/ and /usr/local/lib was there, ran ldconfig, my path was
set, and I still got the same result. So I checked out the config.log and

conftest -g -O2 -I/usr/X11R6/include -I/usr/local/include
-I/usr/local/include/SDL -D_REENTRANT conftest.c -L/usr/local/lib
-Wl,-rpath,/usr/local/lib -lSDL -lpthread 1>&5
/usr/i386-slackware-linux/bin/ld: warning:, needed by
/usr/local/lib/, not found (try using --rpath)
/usr/local/lib/ undefined reference to arts_stream_get' /usr/local/lib/ undefined reference toarts_init’
/usr/local/lib/ undefined reference to arts_play_stream' /usr/local/lib/ undefined reference toarts_stream_set’
/usr/local/lib/ undefined reference to arts_close_stream' /usr/local/lib/ undefined reference toarts_write’
collect2: ld returned 1 exit status
configure: failed program was:
#line 2276 “configure”
#include “confdefs.h”

So i searched my system for and found it in /usr/local/kde/lib/
(i’m using KDE 2.0.1). So for the hell of it i made a symlink to that file in
/usr/local/lib, tried the ./configure again, and it worked! No more problems,
everything compiles fine and all SDL applications work great. Does anybody
have any idea as to why this happened or what caused it? I’m curious as to
what exactly was going on? My system is:

  • Slackware Linux 7.1
  • Kernel 2.2.18
  • XFree86 4.0.1
  • KDE 2.0.1 / QT 2.2.2