SDL_ttf compile problems

Hi, i try to compile SDL_ttf, but i get the following error:

checking for gethostbyname… yes
checking for connect… yes
checking for remove… yes
checking for shmat… yes
checking for IceConnectionNumber in -lICE… yes
checking for OpenGL support… yes
updating cache ./config.cache
creating ./config.status
creating Makefile
creating SDL_ttf.spec
/bin/sh ./libtool --mode=compile gcc -DPACKAGE=“SDL_ttf”
-DVERSION=“2.0.6” -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -I. -I. -g
-O2 -I/usr/include/freetype2 -I/usr/local/include/SDL -D_REENTRANT
-I/usr/X11R6/include -DHAVE_OPENGL -c SDL_ttf.c
mkdir .libs
gcc -DPACKAGE=“SDL_ttf” -DVERSION=“2.0.6” -DHAVE_ALLOCA_H=1
-DHAVE_ALLOCA=1
-I. -I. -g -O2 -I/usr/include/freetype2 -I/usr/local/include/SDL
-D_REENTRANT -I/usr/X11R6/include -DHAVE_OPENGL -c SDL_ttf.c -fPIC
-DPIC -o .libs/SDL_ttf.lo
SDL_ttf.c: In function TTF_OpenFontIndexRW': SDL_ttf.c:276:ft_open_stream’ undeclared (first use in this function)
SDL_ttf.c:276: (Each undeclared identifier is reported only once
SDL_ttf.c:276: for each function it appears in.)
distcc[6658] ERROR: compile on 127.0.0.1 failed
make: *** [SDL_ttf.lo] Error 1

My system:
Distribution: LFS4.0
Kernel Version: 2.4.21
OS Type: Linux
CPU: i686
GCC Version: Configured with: …/gcc-3.2/configure
–prefix=/usr --enable-shared --enable-languages=c,c++
–enable-threads=posix --with-slibdir=/lib --enable-__cxa_atexit
–enable-clocale=gnu

Thanks for your help!
Cedric

commands used:

tar -xjvf freetype-2.1.3.tar.bz2
cd freetype-2.1.3
./configure --prefix=/usr
&& make && make install
vi /etc/ld.so.conf

Begin /etc/ld.so.conf

/usr/lib
/usr/local/lib
/opt/lib
/usr/X11R6/lib

End /etc/ld.so.conf

ldconfig

tar -xzvf SDL_ttf-2.0.6.tar.gz
cd SDL_ttf-2.0.6
./configure && make

Thanks,

Cedric,

Linux believer since KNOPPIX 3.2 / LFS 4.0
-------------- next part -----------------
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.536 / Virus Database: 331 - Release Date: 11/3/03

SDL_ttf.c:276: `ft_open_stream’ undeclared (first use in this function)

Change ft_open_stream to FT_OPEN_STREAM. This is fixed in CVS.

See ya!
-Sam Lantinga, Software Engineer, Blizzard Entertainment

Hi,

Edit SDL_ttf.c and on line 276 change the ft_open_stream to FT_OPEN_STREAM
(i.e. change to caps).

In you run into these sort of problems searching the SDL archives is your
best bet there’s a wealth of knowledge in there.

Anyway hope this helps,

Lee—
Lee Weekes
Densitron Technologies

----- Original Message -----
From: cedric.de.wijs@softhome.net (Cedric)
To:
Sent: Sunday, November 23, 2003 2:36 PM
Subject: [SDL] SDL_ttf compile problems

Hi, i try to compile SDL_ttf, but i get the following error:

checking for gethostbyname… yes
checking for connect… yes
checking for remove… yes
checking for shmat… yes
checking for IceConnectionNumber in -lICE… yes
checking for OpenGL support… yes
updating cache ./config.cache
creating ./config.status
creating Makefile
creating SDL_ttf.spec
/bin/sh ./libtool --mode=compile gcc -DPACKAGE=“SDL_ttf”
-DVERSION=“2.0.6” -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -I. -I. -g
-O2 -I/usr/include/freetype2 -I/usr/local/include/SDL -D_REENTRANT
-I/usr/X11R6/include -DHAVE_OPENGL -c SDL_ttf.c
mkdir .libs
gcc -DPACKAGE=“SDL_ttf” -DVERSION=“2.0.6” -DHAVE_ALLOCA_H=1
-DHAVE_ALLOCA=1
-I. -I. -g -O2 -I/usr/include/freetype2 -I/usr/local/include/SDL
-D_REENTRANT -I/usr/X11R6/include -DHAVE_OPENGL -c SDL_ttf.c -fPIC
-DPIC -o .libs/SDL_ttf.lo
SDL_ttf.c: In function TTF_OpenFontIndexRW': SDL_ttf.c:276:ft_open_stream’ undeclared (first use in this function)
SDL_ttf.c:276: (Each undeclared identifier is reported only once
SDL_ttf.c:276: for each function it appears in.)
distcc[6658] ERROR: compile on 127.0.0.1 failed
make: *** [SDL_ttf.lo] Error 1

My system:
Distribution: LFS4.0
Kernel Version: 2.4.21
OS Type: Linux
CPU: i686
GCC Version: Configured with: …/gcc-3.2/configure
–prefix=/usr --enable-shared --enable-languages=c,c++
–enable-threads=posix --with-slibdir=/lib --enable-__cxa_atexit
–enable-clocale=gnu

Thanks for your help!
Cedric

commands used:

tar -xjvf freetype-2.1.3.tar.bz2
cd freetype-2.1.3
./configure --prefix=/usr
&& make && make install
vi /etc/ld.so.conf

Begin /etc/ld.so.conf

/usr/lib
/usr/local/lib
/opt/lib
/usr/X11R6/lib

End /etc/ld.so.conf

ldconfig

tar -xzvf SDL_ttf-2.0.6.tar.gz
cd SDL_ttf-2.0.6
./configure && make

Thanks,

Cedric,

Linux believer since KNOPPIX 3.2 / LFS 4.0




Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.536 / Virus Database: 331 - Release Date: 11/3/03

At 05:29 PM 11/23/03 +0000, you wrote:

Hi,

Edit SDL_ttf.c and on line 276 change the ft_open_stream to FT_OPEN_STREAM
(i.e. change to caps).

In you run into these sort of problems searching the SDL archives is your
best bet there’s a wealth of knowledge in there.

Anyway hope this helps,

Lee

That did the trick

Thanks!,

Cedric,

Linux believer since KNOPPIX 3.2 / LFS 4.0
-------------- next part -----------------
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.536 / Virus Database: 331 - Release Date: 11/3/03