SDL_ttf on OSX


I’m trying to write a simple kids game using SDL, and found SDL_ttf,
which looks awesome (fills a huge need in my app). And, it works great
in linux (debian/sid). However, when I try to run my app on OSX (after
doing some wierdness to get it to compile*), it immediately bombs out with a
bus error. I can’t even get it to load in the debugger within Project
Builder. Any ideas what could be wrong? I’m using the latest stable release
of SDL available as on OSX binary, as well as the latest OSX binary of
SDL_ttf from the webpage. I’ve installed the -dev packages for both. I
don’t really know what else to do.

Oh, if it matters, I was trying to compile my app from the commandline
at first, and for -lSDL, I just used -L~/Library/Frameworks/SDL.framework/SDL,
and that worked fine. But when I tried to do the same with SDL_ttf, it
complained that it wasn’t able to find a file for SDL_ttf. I double and
triple checked that I was using the right directories, it was just like ld
couldn’t use SDL_ttf. But, on the other hand, from within PB it links just
fine. So I dunno…

My relevant specs are:
iBook 300Mhz w/284MB ram
OSX 10.2.[7|8] (whichever’s the latest)
gcc 3.1

Any advice or pointers would be gladly accepted, and if you need more
info just ask! The code itself is modified version of the file 'showfont.c’
that comes with SDL_ttf. Available upon request…


*That is, I had to manually specify the Headers directory in my build conf
within PB, instead of just being able to use the “Add Framework”, and
everything taking care of itself. I haven’t done enough OSX development to
know if that is normal–