SDL with dxr3 game emulation

I am currently running a (Linux) Freevo system, Which uses SDL-1.2.6
to output all recorded TV and Movies through a dxr3 card (Hollywood+)
onto my television. I use this as a standalone box, to record TV,
playback recorded TV, play mp3s, play DVD movies, and to play DVD rips.
I am trying to add the ability to play emulated games also and this is
where I am running into problems. I am trying to use 4 different open
source game emulators (NES=fceu, SNES=zsnes-1.36, Genesis=dgen-sdl-1.23,
ARCADE=xmame-0.80.1). They do not work with my dxr3 which uses a patched
SDL but if I pipe the output thru my voodoo3 card, they do. Here is the
output I get from them and ill also put in the dxr3 SDL patch.

This is the error I used to get with xmame…

/SDL: No Viddepth_8 in Viddepth_16/

I went into my lilo.conf and changed from 256 colors to 64k colors and
solved that problem, it happend in both voodoo3 and dxr3. I now have a
fully functional emulator box with my voodoo3 card but it is such a
crappy card that it isn’t worth it. I would really like to get the dxr3
card to work. /I believe it is sending the output to the Monitor instead
of the dxr3 tv-output./ I just confirmed that, I plugged in a monitor
and the picture was coming up on the monitor and not on dxr3 card.
That’s why I was getting sound but no picture. Is this an SDL problem?

When I start fceu, I get this…
[root at Freevo]</opt/media/games/nes/roms> fceu -xres 640 -yres 480 -fs 1
-doublebuf -soundvol 100 10yardf.nes

Starting FCE Ultra 0.98.5…
Loading 10yardf.nes…

PRG ROM: 2 x 16KiB
CHR ROM: 1 x 8KiB
ROM CRC32: 0x917c55d8
ROM MD5: 0x33a46775c9d76149b7623a43b60be9db
Mapper: 0
Mirroring: Vertical

Initializing video… Video Mode: 640 x 480 x 8 bpp full screen

Initializing sound…
Bits: 16
Rate: 48000
Channels: 1
Byte order: CPU Native
Buffer size: 1152 sample frames(24.000000 ms)

When T start zsnes, I get this…
[root at Freevo]</opt/media/games/snes/roms> zsnes -1 1 -n -om -z -m -r 3
-k 100 -cs -t MaddenNFL93.smc

ZSNES v1.36 © 1997-2002, ZSNES Team (zsKnight & Demo)

Be sure to check for the latest version.
Please report crashes to zsnes-devel at

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions;
please read ‘LICENSE’ thoroughly before using it.

Use ZSNES -? for command line definitions.

MMX support found and enabled.

File opened successfully!

Max 48mbit ROM support + SuperFX/C4 support + 16bit New Gfx Engine

Filename : MaddenNFL93.srm
Frame Skip : AUTO
Debugger : OFF

Memory Free :

Cartridge name : Madden Football '93
Memory Map : 20
ROM size : Megabits
SRAM size : Kilobytes
ROM Type : PAL
Checksum : PASSED
NMI Vector Location : B727
Reset Vector Location : 8000

Press Any Key to Continue.
ZSNES could not find any joysticks.

When I start xmame, I get this…
SDL: Info: SDL initialized
info: trying to parse: /usr/local/share/xmame/xmamerc
info: trying to parse: /root/.xmame/xmamerc
info: trying to parse: /usr/local/share/xmame/xmame-SDLrc
info: trying to parse: /root/.xmame/xmame-SDLrc
info: trying to parse: /usr/local/share/xmame/rc/airwolfrc
info: trying to parse: /root/.xmame/rc/airwolfrc
loading rom 0: b.2s
loading rom 1: a.7s
loading rom 2: f.4a
loading rom 3: 09h_14.bin
loading rom 4: 10h_13.bin
loading rom 5: 11h_12.bin
loading rom 6: e.6a
loading rom 7: d.8a
loading rom 8: c.10a
loading rom 9: 01j.bin
loading rom 10: 01h.bin
loading rom 11: 01f.bin
loading rom 12: m1.2c
SDL: Info: Video mode set as 640 x 480, depth 16
Initializing video effect 7: bitmap depth = 16, display depth = 16
OSD: Warning: unknown joytype: 1, or joytype not compiled in.
Disabling joystick support.
Using 16bpp video mode
SDL: sysdep_display_alloc_palette(65536);
info: set to 16bit linear mono 22050Hz
info: sysdep_dsp: using alsa plugin
info: sysdep_mixer: using oss plugin

When I run dgen, I get this…
[root at Freevo]</opt/media/games/genesis/roms> dgen -f -S 2 sonic2.smd
21 frames per second (optimal 60)