SDL without X

Hello! Well, I have my SDL application running happily on X (through the DGA
extension), using the nvidia driver, with double buffer, hardware
acceleration, etc.

What’s the best way to make it work without X?

Thanks!

Carlos

Hello! Well, I have my SDL application running happily on X (through the DGA
extension), using the nvidia driver, with double buffer, hardware
acceleration, etc.

What’s the best way to make it work without X?

The simplest way is to set up the framebuffer console and just run the
app from the console.

See ya,
-Sam Lantinga, Software Engineer, Blizzard Entertainment

Hi, I’m just starting to learn SDL, i’ve got a project which requires it
and before i release any files for the project i want to get myself
atleast proficient.

The thing is i don’t want to be running X for my SDL applications and
while testing my applications in X I get good results, the images load
in the right place but when i try to run them without X i don’t get any
images. Should i be linking in something else into my application to get
full functionality of SDL on the framebuffer?

Thanks

Karl

Not really, I run my app on X and on Framebuffer perfectly without
change, did you have framebuffer enable? (vga = 7xx on kernel?), did you
have your gpm enable?

Tell us something more about your environment and how are you calling
SDL.On Fri, 2003-11-28 at 10:26, Karl Lattimer wrote:

Hi, I’m just starting to learn SDL, i’ve got a project which requires
it and before i release any files for the project i want to get myself
atleast proficient.

The thing is i don’t want to be running X for my SDL applications and
while testing my applications in X I get good results, the images load
in the right place but when i try to run them without X i don’t get
any images. Should i be linking in something else into my application
to get full functionality of SDL on the framebuffer?

Thanks

Karl

Karl Lattimer escreveu:

Hi, I’m just starting to learn SDL, i’ve got a project which requires it
and before i release any files for the project i want to get myself
atleast proficient.

The thing is i don’t want to be running X for my SDL applications and
while testing my applications in X I get good results, the images load
in the right place but when i try to run them without X i don’t get any
images. Should i be linking in something else into my application to get
full functionality of SDL on the framebuffer?

Hello Karl.

Are you sure your framebuffer is OK? There should be no problems runnig
anything on fb that has worked on X.

[]s

Adilson.